Unable to deploy static site

Mar 19 02:57:01 AM==> Checking out commit 3cc498102593096bc8e29d68fe605896174d6bfe in branch master

Mar 19 02:57:04 AM==> Using Node version 16.17.0 via /opt/render/project/src/client/.node-version

Mar 19 02:57:04 AM==> Docs on specifying a Node version:

Mar 19 02:57:08 AM==> Using Ruby version 3.2.2 (default)

Mar 19 02:57:08 AM==> Docs on specifying a Ruby version:

Mar 19 02:57:09 AM==> Installing dependencies with npm…

Mar 19 02:57:23 AM

Mar 19 02:57:23 AMadded 816 packages, and audited 817 packages in 14s

Mar 19 02:57:23 AM

Mar 19 02:57:23 AM84 packages are looking for funding

Mar 19 02:57:23 AM run npm fund for details

Mar 19 02:57:24 AM

Mar 19 02:57:24 AM56 vulnerabilities (44 moderate, 12 high)

Mar 19 02:57:24 AM

Mar 19 02:57:24 AMTo address issues that do not require attention, run:

Mar 19 02:57:24 AM npm audit fix

Mar 19 02:57:24 AM

Mar 19 02:57:24 AMSome issues need review, and may require choosing

Mar 19 02:57:24 AMa different dependency.

Mar 19 02:57:24 AM

Mar 19 02:57:24 AMRun npm audit for details.

Mar 19 02:57:26 AM

Mar 19 02:57:26 AMup to date, audited 817 packages in 2s

Mar 19 02:57:26 AM

Mar 19 02:57:26 AM84 packages are looking for funding

Mar 19 02:57:26 AM run npm fund for details

Mar 19 02:57:26 AM

Mar 19 02:57:26 AM56 vulnerabilities (44 moderate, 12 high)

Mar 19 02:57:26 AM

Mar 19 02:57:26 AMTo address issues that do not require attention, run:

Mar 19 02:57:26 AM npm audit fix

Mar 19 02:57:26 AM

Mar 19 02:57:26 AMSome issues need review, and may require choosing

Mar 19 02:57:26 AMa different dependency.

Mar 19 02:57:26 AM

Mar 19 02:57:26 AMRun npm audit for details.

Mar 19 02:57:49 AM==> Using Python version 3.11.8 (default)

Mar 19 02:57:49 AM==> Docs on specifying a Python version: Setting Your Python Version | Render Docs

Mar 19 02:57:55 AM==> Using Poetry version 1.7.1 (default)

Mar 19 02:57:55 AM==> Docs on specifying a Poetry version: Specifying a Poetry Version | Render Docs

Mar 19 02:57:55 AM==> Installing Poetry version 1.7.1

Mar 19 02:58:14 AMRetrieving Poetry metadata

Mar 19 02:58:14 AM

Mar 19 02:58:14 AM# Welcome to Poetry!

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMThis will download and install the latest version of Poetry,

Mar 19 02:58:14 AMa dependency and package manager for Python.

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMIt will add the poetry command to Poetry’s bin directory, located at:

Mar 19 02:58:14 AM

Mar 19 02:58:14 AM/opt/render/project/poetry/bin

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMYou can uninstall at any time by executing this script with the --uninstall option,

Mar 19 02:58:14 AMand these changes will be reverted.

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMInstalling Poetry (1.7.1)

Mar 19 02:58:14 AMInstalling Poetry (1.7.1): Creating environment

Mar 19 02:58:14 AMInstalling Poetry (1.7.1): Installing Poetry

Mar 19 02:58:14 AMInstalling Poetry (1.7.1): Creating script

Mar 19 02:58:14 AMInstalling Poetry (1.7.1): Done

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMPoetry (1.7.1) is installed now. Great!

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMTo get started you need Poetry’s bin directory (/opt/render/project/poetry/bin) in your PATH

Mar 19 02:58:14 AMenvironment variable.

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMAdd export PATH="/opt/render/project/poetry/bin:$PATH" to your shell configuration file.

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMAlternatively, you can call Poetry explicitly with /opt/render/project/poetry/bin/poetry.

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMYou can test that everything is set up by executing:

Mar 19 02:58:14 AM

Mar 19 02:58:14 AMpoetry --version

Mar 19 02:58:14 AM

Mar 19 02:58:14 AM==> Running build command ‘npm run build’…

Mar 19 02:58:14 AM

Mar 19 02:58:14 AM> client@1.0.0 build

Mar 19 02:58:14 AM> parcel build index.html

Mar 19 02:58:14 AM

Mar 19 02:58:56 AM🚨 /opt/render/project/src/client/node_modules/date-fns/areIntervalsOverlapping.js: Unexpected token: punc (.)

Mar 19 02:58:56 AM at Z.get (/opt/render/project/src/client/node_modules/terser/dist/bundle.min.js:1:525)

Mar 19 02:58:56 AM at Object.errorToJson (/opt/render/project/src/client/node_modules/@parcel/utils/src/errorUtils.js:9:20)

Mar 19 02:58:56 AM at Pipeline.process (/opt/render/project/src/client/node_modules/parcel-bundler/src/Pipeline.js:29:26)

Mar 19 02:58:56 AM at async Object.run (/opt/render/project/src/client/node_modules/parcel-bundler/src/worker.js:15:12)

Mar 19 02:58:56 AM at async Bundler.loadAsset (/opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:577:19)

Mar 19 02:58:56 AM at async /opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:610:13

Mar 19 02:58:56 AM at async Promise.all (index 14)

Mar 19 02:58:56 AM at async Bundler.loadAsset (/opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:599:21)

Mar 19 02:58:56 AM at async /opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:610:13

Mar 19 02:58:56 AM at async Promise.all (index 2)

Mar 19 02:58:56 AM at async Bundler.loadAsset (/opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:599:21)

Mar 19 02:58:56 AM at async /opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:610:13

Mar 19 02:58:56 AM at async Promise.all (index 1)

Mar 19 02:58:56 AM at async Bundler.loadAsset (/opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:599:21)

Mar 19 02:58:56 AM at async Bundler.processAsset (/opt/render/project/src/client/node_modules/parcel-bundler/src/Bundler.js:557:5)

Mar 19 02:58:56 AM at async PromiseQueue._runJob (/opt/render/project/src/client/node_modules/parcel-bundler/src/utils/PromiseQueue.js:48:7)

Mar 19 02:58:58 AM==> Build failed :disappointed:

=================================================
package.json

{
“name”: “client”,
“version”: “1.0.0”,
“description”: “”,
“main”: “index.js”,
“scripts”: {
“start”: “parcel index.html”,
“build”: “parcel build index.html”
},
“keywords”: ,
“author”: “”,
“license”: “ISC”,
“dependencies”: {
“axios”: “^1.6.7”,
“date-fns”: “^3.5.0”,
“parcel-bundler”: “^1.12.5”
},
“devDependencies”: {
“parcel-bundler”: “^1.12.5”
}
}

Hi,

The main error there appears to be:

Unexpected token: punc (.)

Which may be related to parcel? https://github.com/parcel-bundler/parcel/issues/4458

Alan