The Deploy is success but still the web is not working

when i open the web :

im getting :

Error: ENOENT: no such file or directory, stat ‘/opt/render/project/src/public/index.html’

someone know why?


The error is saying you don’t have a file matching public/index.html in your repo.

That could be for a couple of reasons:

  • Linux is case sensitive, so public/index.html would be a different to Public/Index.html
  • The files simply doesn’t exist.
  • Maybe you need to build that file as part of the Build Command.

You’ll know your app better than us.


this is my repo

everthing looks good, and its still not working

still getting error
can you help me?


Render support is not able to provide general code debugging. However, even if other community members did want to try and help, you’ve provided very little information.

What type of service is this (Static, Web Service, etc.)? Is the error still the same as when you opened it last week? What have you tried? What are your Build & Start Commands? Are you using any other settings, Root Directory, etc.?

You need to elaborate on your issue in as much detail as possible, e.g. logs/error messages (not just single lines), reproduction steps, screenshots, etc. to show the problem you’re experiencing.


its a web servise, react and nodejs with mongodb,
my build Commands is npm run build
and my start Commands is npm run start
now im getting: Server unhealthy
Exited with status 1 while running your code.
with log of:
1:19 AM (node:64) [MONGOOSE] DeprecationWarning: Mongoose: the strictQuery option will be switched back to false by default in Mongoose 7. Use mongoose.set('strictQuery', false); if you want to prepare for this change. Or use mongoose.set('strictQuery', true); to suppress this warning.
Feb 21 11:01:19 AM (Use node --trace-deprecation ... to show where the warning was created)

Those logs only look like a warning not an error/exit.

If you’re running those npm commands in the root of the project you shared (and you haven’t set a Root Directory to the client folder) then, the underlying “build” and “start” scripts look correct.

Are you seeing any other logs, or have you set (or are you missing) any environment variables your project needs?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.