Static site on old version

Our static site srv-bpmjgoj4ttttiup114ag has been deployed several times but is still showing old files:

The latest version of /service-worker.js, as per the deploy, should contain the string “runtime-main.e474865f.js”, but instead contains “runtime-main.b2e32c00.js”. The same is true for other files, they’re all returning old versions, despite having manually re-deployed.

And it looks like the cache just got cleared…not sure if this was related to today’s incident but would love some details on what happened/if it’s likely to happen again, as we’ve had at least 2 other incidents of this shape.

Hi @bkrausz, we’ll investigate and follow up. This doesn’t seem related to today’s incident.

Similar thing is happening with my static site as well (serving old files). Similarly, newly-added redirect rules are not correctly redirecting either.

I tried manual redeploys as well, even after the previous incident was cleared, to no avail.

Thanks! I am inconsistently still seeing the issue.

I’m also seeing this issue inconsistently.

I’ve been seeing weird things all evening too, like stale deployed pages, and a static site I can’t seem to get online at all (although I’m still new to Render so I don’t know what’s normal).

I wonder if this error is related. I just it got manually (re)deploying a static site:

Mar 11 12:08:03 AM fatal: unable to access '': Could not resolve host:

(Not complaining, just hoping that helps.)

Wanted to mention that I got the exact same error message before as well:
fatal: unable to access 'https://x-access-token:v1.<redacted><org>/<repo>.git/‘: Could not resolve host:

It later resolved (later builds were marked as successes without this error), but I’m still seeing old files being served.

1 Like

Same, seems better now. resolves, build worked.

@bkrausz @jasonwang @anemicshark @Spacehaven We did see an elevated rate of failed builds tonight, many of them due to DNS resolution errors. We’re investigating this and the stale cache issue and will update you tomorrow. Thank you for your patience.

Hey David, Is this issue still occurring? I’m seeing some similar things on my builds as well.

@david We are still seeing this on our sites as well - old versions of the website showing on different refreshes.

1 Like

Hey all, we are continuing to investigate, and will update our status page to reflect the degraded performance.

Follow for updates

We think we’ve identified and fixed the cause. Is anyone on this thread continuing to see issues?


It’s resolved for me! Thanks @david :slight_smile:

1 Like

Faced the described problem today. Can confirm that it has been fixed for me. The latest version of all assets is served. Everything looks fine. Thanks!

1 Like

@david I’ve just run into this issue during a static build

Although now after trying for the 4th time it seems to have worked…

@christianechevarria please let us know if you continue to see issues.