[SOLVED] Infinite loading for all of our services in Frankfurt region from Nigeria

Hi!

We’ve received several reports from our users in Nigeria that trying to connect to our services loads infinitely. It happens for our API (api[dot]useaccrue.com) and blog (blog[dot]useaccrue.com).

We’ve confirmed that this is a Render issue because we have a staging environment on Heroku that’s accessible by my co-founder in Nigeria.

I’d appreciate any help with pinpointing the issue.

We’ve seen an uptick in customers getting in touch that your own customers are having problems accessing your services on Render from Nigeria.

I would if you’d be able to provide the output of a

curl -I https://<your service-address>

and then we can attempt to diagnose a cause. It could be a number of things from an issue with CloudFlare through to local ISP issues,

Regards,

It happens intermittently. At first, I thought it was because I was using free tier services, and it wasn’t a priority to the team.

Until I couldn’t access paid services, render.com, and the dashboard for more than 24 hours.

I tried with multiple ISPs and asked a few friends to try the links. It was like we got shut off from the whole render network.

We will be moving to production soon, and I am a bit sceptical about the reliability of render services.

I agree with @Olu. It’s intermittent. In our case, the issue resolved itself the day after I made the post. The next time it happens, I’ll get the curl output.

Before yesterday, we had outages on specific ISPs (especially Airtel) when every other one was working. Sometimes it looked like DNS servers were out. I say this because the 1.1.1.1 app gave us uninterrupted access.

It’s happening right now. I can’t reach the render website, the dashboard and my web service. Unless I use the 1.1.1.1 app.

Connection timeout screenshot…

As I mentioned earlier, I can’t any service on render’s network. @Clinton_Mbah, I can’t reach the URL you posted earlier.

I have 3 ISPs with dynamic IP addresses. I am guessing a firewall won’t be able to block the 3 at the same time.

My friend in a different location can reach the services too.

I’m having the same issue in Nigeria as well.

We are continuing to assist customers diagnose where the issue lies with this.

The output of the curl:

curl -I https://<your-service> --resolve <your-service>:443:34.83.64.96

would also be most useful for debugging purpose.

ok, so that rules out it being a CloudFlare issue.

How about some traceroute outputs to dashboard.render.com and your own services on Render, then we can see if we can stop some commonalities in failure point.

I’m experiencing the same issue with my services.

@John_B output of curl here too

Also, curious what output https://dashboard.render.com/cdn-cgi/trace shows in the browser please.

Just to update here, all we have so far from 1 customer is that traceroute is getting stopped at 41.220.75.226 which is an IP address owned by mtnnigeria.net

In order to assist us further here please can anyone experiencing this provide us with:

Thanks!

@John_B

1 Like

@John_B

Trace route to my service

1 Like

@John_B

Seems to be an MTNNigeria issue.

Here’s a trace route with Glo Nigeria

The browser request also went through.

I can’t access with airtel and IPNX too.

@John_B

Please, any update from your end on this?