Site deployed, but shows "Not found"

Hello,

I’m migrating over a web app/ site that I used to have on heroku (for a class project). I was able to get it to successfully deploy on render, with a “uploading build” → “your site is live” log messages showing, but the site itself only shows a blank “Not Found” message.

Can somebody help me out? My site is: https://simulateportfolio.onrender.com/

Hey there

The http response is 404 - which is Not found. Basically your website is not serving anything, there is no index.html or anything that the server would show…

How is your app set up? Is it a web service or a static web?

I was having the same issues for my Django app so I can only talk to you as a Django developer your html pages are not yet configured yet that’s why you are getting a not found error meaning that the location or root where your website points to is not having any html file or index.html file check in your development side if you are able to access your homepage

im having the exact same problem with next.js anyone have ideas? My app works on development and I have it pointet to .next as the publish folder.

Edit: I figured out I just had to deploy as a web server. Im kinda a noob at deployments. But yea that fixed it

Hi all,

“Me too” posts without providing any real detail makes it pretty hard to provide any specific advice.

If a Static Site is just showing Not found after a successful deploy, then it’s not finding a static index.html file in the “Publish Directory” that you’ve set. Best place to start would be checking your code configuration, e.g. is your build command actually creating your static files where you set the Publish Directory, etc.

If you feel you still have an issue, please feel free to raise a ticket from the “Contact Support” link at the bottom of the Dashboard and share some specific details on what you’ve tried, any logs/output, etc.

Thanks

Alan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.