Response Timeout?

Hello,

I was reading this document: Render vs Heroku Comparison — Discover the Heroku Alternative for Developers | Render
It says that: “Render allows responses to take up to 100 minutes for HTTP requests. Heroku has a hard response timeout of 30 seconds and it can not be configured or changed.

However, I recently deployed a Django Gunicorn Webapp that gets a WORKER TIMEOUT error on a long running task. In my use case, it is quite difficult to move this to a background task currently and I was hoping to keep it as a long running request, since the docs mentioned upto 100 mins for a request. In reality the request will only take about a minute, but it seems to be timed-out after 30 seconds or so. Is there something I can do to change this? Is this a gunicorn setting (and if so can I change the gunicorn settings somehow)

This is one of the reasons I wanted to switch from heroku to render but I can’t seem to figure out how to prevent a timeout.

Thanks,
Julian

Figured it out!

We can set gunicorn settings, as documented from here:
https://docs.gunicorn.org/en/stable/settings.html

used the --timeout flag in the web service start command to set my custom timeout :slight_smile: :smile:

So my start command is now: gunicorn --timeout 120 --log-file -

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.