Node Build failed with npm

I’m trying to deploy a node application on web service.
The build seems to be failing.
I have changed the build in the scripts to npm install. still same error.
I’ve tried changing the node version from 12.15.0 to 16.0.0 but I’m still encountering a build error

what possible solution could work


The top of that screenshot looks like the end of the npm usage help.

$ npm
npm <command>


npm install         install all the dependencies in your project
npm install <foo>    add the <foo> dependency to your project
npm test             run this project's tests
npm run <foo>        run the script named <foo>
npm <command> -h     quick help on <command>
npm -l               display usage info for all commands
npm help <term>      search for help on <term>
npm help npm         more involved overview

The npm command on it’s own doesn’t do anything, it needs an action, like npm install or npm run build.



In my package.json file
npm install is present there

but I don’t know why it only runs npm

Attached is also the render log

I kept editing and retrying

I have no idea why the npm install isn’t running when it is present in the json file

That is running what you have set as the “Build Command” on the service “Settings” page. I’d suggest not using a package.json script to run npm install - just add that directly in the “Build Command”.


Thank you Alan!

Editing the build command from the settings worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.