No open HTTP ports detected

I’m trying to deploy a Dash app, and keep getting the error message from Render ‘No open HTTP ports detected’ upon deployment. I used dash-tools to help me create the render.yaml file, am confident I have a valid requirements.txt, and added the line ‘server=app.server’ in the app.py file. How can I fix this error? I’ve tried multiple tutorials and followed the exact same steps, but their apps deploy and mine is encountering this error.

1 Like

Ensure the server is listening on 0.0.0.0, and not 127.0.0.1.

Hey, I’m having the same issue.
I’ve seen this answer a couple times, My server deployed perfectly, However the client deploy stays ‘in progress’ because there’s that error as ‘underwood-scott’ posted.
“Sep 8 08:37:54 PM ➜ Local: http://127.0.0.1:5173/
Sep 8 08:37:54 PM ➜ Network: use --host to expose
Sep 8 08:41:06 PM ==> No open HTTP ports detected
Sep 8 08:41:07 PM ==> Web Services | Render · Cloud Hosting for Developers
Even though it does write the build was successful …

Hello @shwartzie, I had the same problem. I solved it by going to the environments on the left side of the dashboard (left to the log where you see the error) then added by apikey. E.g if you have an OPENAI key, input it the same way it appears in your code and it worked. I don’t really if that’s what caused the error but it solved my issue.

I got this error in a React app that I created with Vite. I solved it by editing the viteconfig.ts file and changing the following code

from:

plugins: [react()],
resolve: {

to:

plugins: [react()],
server: {
host: true,
strictPort: true,
port: 8000,
},
resolve: {

I hope this helps someone…

4 Likes

Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.