Network error when downloading dependencies from docker build

Hi all, recently got connection issues when running wget steps inside my Dockerfile when doing docker build. The thing is, just few weeks ago the same dockerfile works fine and when I tried the docker builds on the github actions I found no problem at all. This is the error that I get:

#27 ERROR: process "/bin/sh -c wget -q \"\"" did not complete successfully: exit code: 4

Is there any restriction in render regarding to downloading files within docker build steps?

According to wget(1): non-interactive network downloader - Linux man page , Exit Code 4 is a Network failure. It’s not easily possible to say if it was the container, or the destination, or what happened, retrospectively.

Oddly enough, after I run the build steps again after some time, suddenly it works again without any problem. Probably there was some intermittent network issues within Render at that time, so I guess trying to run the build steps again after some time is the workaround for this issue

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.