Migration From Heroku Keeps Failing

Followed the guide to the letter, still didn’t work. Here’s the log.
Also why the hell does it keep trying to use YARN? I hate yarn!

Jan 23 12:19:55 PM  ==> Cloning from https://github.com/genxhero/swyle...
Jan 23 12:19:55 PM  ==> Checking out commit 7797ec7f13e302c838b481f91a80d82ab7b3cd96 in branch master
Jan 23 12:19:59 PM  #1 [internal] load .dockerignore
Jan 23 12:19:59 PM  #1 transferring context: 2B done
Jan 23 12:19:59 PM  #1 DONE 0.0s
Jan 23 12:19:59 PM  
Jan 23 12:19:59 PM  #2 [internal] load build definition from Dockerfile.render
Jan 23 12:19:59 PM  #2 transferring dockerfile: 2.70kB done
Jan 23 12:19:59 PM  #2 DONE 0.0s
Jan 23 12:19:59 PM  
Jan 23 12:19:59 PM  #3 [internal] load metadata for ghcr.io/renderinc/heroku-app-builder:v4-heroku-18
Jan 23 12:20:00 PM  #3 ...
Jan 23 12:20:00 PM  
Jan 23 12:20:00 PM  #4 [internal] load metadata for ghcr.io/renderinc/heroku-app-runner:v4-heroku-18
Jan 23 12:20:00 PM  #4 DONE 1.0s
Jan 23 12:20:00 PM  
Jan 23 12:20:00 PM  #3 [internal] load metadata for ghcr.io/renderinc/heroku-app-builder:v4-heroku-18
Jan 23 12:20:00 PM  #3 DONE 1.1s
Jan 23 12:20:00 PM  
Jan 23 12:20:00 PM  #5 [runner 1/4] FROM ghcr.io/renderinc/heroku-app-runner:v4-heroku-18@sha256:e5793842e8a43121e177fb68882eae183703fd40d90be81b1ab06e96b693a5d6
Jan 23 12:20:00 PM  #5 resolve ghcr.io/renderinc/heroku-app-runner:v4-heroku-18@sha256:e5793842e8a43121e177fb68882eae183703fd40d90be81b1ab06e96b693a5d6 done
Jan 23 12:20:00 PM  #5 ...
Jan 23 12:20:00 PM  
Jan 23 12:20:00 PM  #6 [builder 1/3] FROM ghcr.io/renderinc/heroku-app-builder:v4-heroku-18@sha256:4f314b7f6d7b299089227a2032b53b8b53010950090367ffb6d647ee9238c5ce
Jan 23 12:20:00 PM  #6 resolve ghcr.io/renderinc/heroku-app-builder:v4-heroku-18@sha256:4f314b7f6d7b299089227a2032b53b8b53010950090367ffb6d647ee9238c5ce done
Jan 23 12:20:00 PM  #6 DONE 0.2s
Jan 23 12:20:00 PM  
Jan 23 12:20:00 PM  #5 [runner 1/4] FROM ghcr.io/renderinc/heroku-app-runner:v4-heroku-18@sha256:e5793842e8a43121e177fb68882eae183703fd40d90be81b1ab06e96b693a5d6
Jan 23 12:20:01 PM  #5 ...
Jan 23 12:20:01 PM  
Jan 23 12:20:01 PM  #7 [internal] load build context
Jan 23 12:20:01 PM  #7 transferring context: 1.70MB 0.3s done
Jan 23 12:20:01 PM  #7 DONE 0.3s
Jan 23 12:20:01 PM  
Jan 23 12:20:01 PM  #5 [runner 1/4] FROM ghcr.io/renderinc/heroku-app-runner:v4-heroku-18@sha256:e5793842e8a43121e177fb68882eae183703fd40d90be81b1ab06e96b693a5d6
Jan 23 12:20:01 PM  #5 extracting sha256:6e3729cf69e0ce2de9e779575a1fec8b7fb5efdfa822829290ab6d5d1bc3e797
Jan 23 12:20:03 PM  #5 extracting sha256:6e3729cf69e0ce2de9e779575a1fec8b7fb5efdfa822829290ab6d5d1bc3e797 1.9s done
Jan 23 12:20:03 PM  #5 extracting sha256:bd8f77740bcddf454f575eb3ea236dc0981018d5df3a2de2ad768b06edaac442
Jan 23 12:20:04 PM  #5 extracting sha256:bd8f77740bcddf454f575eb3ea236dc0981018d5df3a2de2ad768b06edaac442 0.3s done
Jan 23 12:20:04 PM  #5 extracting sha256:3b384feac638bbe2c8a36df3e818500fa59770c3c742b9d5d3cb96d0495a10d6
Jan 23 12:20:05 PM  #5 ...
Jan 23 12:20:05 PM  
Jan 23 12:20:05 PM  #6 [builder 1/3] FROM ghcr.io/renderinc/heroku-app-builder:v4-heroku-18@sha256:4f314b7f6d7b299089227a2032b53b8b53010950090367ffb6d647ee9238c5ce
Jan 23 12:20:05 PM  #6 sha256:4f4fb700ef54461cfa02571ae0db9a0dc1e0cdb5577484a6d75e68dc38e8acc1 32B / 32B 0.2s done
Jan 23 12:20:05 PM  #6 sha256:29337de1a40eab7f9ac46d6412d370f98a79ab31384ff0b0f0b09a4cac73165b 50.22MB / 50.22MB 1.1s done
Jan 23 12:20:05 PM  #6 sha256:f9f2012c6fce89e42fa171ef0d9fe7912f598e5cf2519f2955d6415e1c0bc034 1.38kB / 1.38kB 0.3s done
Jan 23 12:20:05 PM  #6 sha256:e3ba89dbcefff64f98e7c9e2d6440c631919f56af1c1913001115b5679082d88 50.21MB / 50.21MB 1.2s done
Jan 23 12:20:05 PM  #6 sha256:6c6e61c8cea3e27da3b6cf69a85f5a8efa1487786f23ed9d7cb871bbfa00d9fd 292B / 292B 0.3s done
Jan 23 12:20:05 PM  #6 sha256:50502b5bad46605e2fbf49bb5165e32da9039ff2a4b1827d5d1b63d34aa9bf4b 328B / 328B 0.3s done
Jan 23 12:20:05 PM  #6 sha256:2a6c162ed30fa8ffaa3806fa94e8bbaa4e9068d60ac3d1da5dea4946dfabda47 244B / 244B 0.5s done
Jan 23 12:20:05 PM  #6 sha256:c8214c76646d7ab73f2281e6826f6419f723b8cc4d26db37c25baf1718b6d069 3.80kB / 3.80kB 0.5s done
Jan 23 12:20:05 PM  #6 sha256:f391845c88e56ed90ecfb9d6344310036d18cd6dae67cb237ecc9636e7f917cb 117.27MB / 117.27MB 2.3s done
Jan 23 12:20:05 PM  #6 sha256:c3a91c657f4c013f119d458beb1ccfd5d2102cd00b909e0fdcb2f2b85b4300c2 739B / 739B 0.3s done
Jan 23 12:20:05 PM  #6 DONE 4.5s
Jan 23 12:20:05 PM  
Jan 23 12:20:05 PM  #5 [runner 1/4] FROM ghcr.io/renderinc/heroku-app-runner:v4-heroku-18@sha256:e5793842e8a43121e177fb68882eae183703fd40d90be81b1ab06e96b693a5d6
Jan 23 12:20:11 PM  #5 extracting sha256:3b384feac638bbe2c8a36df3e818500fa59770c3c742b9d5d3cb96d0495a10d6 7.9s done
Jan 23 12:20:11 PM  #5 extracting sha256:4879ba558ba7698ad374e7b2239f3e78d7d7b7c15a316ed860e0ac8ff43c3277 done
Jan 23 12:20:11 PM  #5 extracting sha256:21e64a28906def121b6bed1a62108dc7ec00f5efe282a3767e57f4c4de916a8b done
Jan 23 12:20:11 PM  #5 extracting sha256:db446846fc14a430a9942fe982b19c4da0e12c6de42609af539817aea4df8b65 done
Jan 23 12:20:11 PM  #5 DONE 11.3s
Jan 23 12:20:11 PM  
Jan 23 12:20:11 PM  #6 [builder 1/3] FROM ghcr.io/renderinc/heroku-app-builder:v4-heroku-18@sha256:4f314b7f6d7b299089227a2032b53b8b53010950090367ffb6d647ee9238c5ce
Jan 23 12:20:11 PM  #6 extracting sha256:c3a91c657f4c013f119d458beb1ccfd5d2102cd00b909e0fdcb2f2b85b4300c2 done
Jan 23 12:20:11 PM  #6 extracting sha256:f391845c88e56ed90ecfb9d6344310036d18cd6dae67cb237ecc9636e7f917cb
Jan 23 12:20:17 PM  #6 extracting sha256:f391845c88e56ed90ecfb9d6344310036d18cd6dae67cb237ecc9636e7f917cb 5.1s done
Jan 23 12:20:17 PM  #6 extracting sha256:2a6c162ed30fa8ffaa3806fa94e8bbaa4e9068d60ac3d1da5dea4946dfabda47 done
Jan 23 12:20:17 PM  #6 extracting sha256:c8214c76646d7ab73f2281e6826f6419f723b8cc4d26db37c25baf1718b6d069 done
Jan 23 12:20:17 PM  #6 extracting sha256:50502b5bad46605e2fbf49bb5165e32da9039ff2a4b1827d5d1b63d34aa9bf4b done
Jan 23 12:20:17 PM  #6 extracting sha256:6c6e61c8cea3e27da3b6cf69a85f5a8efa1487786f23ed9d7cb871bbfa00d9fd done
Jan 23 12:20:17 PM  #6 extracting sha256:e3ba89dbcefff64f98e7c9e2d6440c631919f56af1c1913001115b5679082d88
Jan 23 12:20:18 PM  #6 extracting sha256:e3ba89dbcefff64f98e7c9e2d6440c631919f56af1c1913001115b5679082d88 1.3s done
Jan 23 12:20:18 PM  #6 extracting sha256:f9f2012c6fce89e42fa171ef0d9fe7912f598e5cf2519f2955d6415e1c0bc034 0.0s done
Jan 23 12:20:18 PM  #6 extracting sha256:29337de1a40eab7f9ac46d6412d370f98a79ab31384ff0b0f0b09a4cac73165b
Jan 23 12:20:19 PM  #6 extracting sha256:29337de1a40eab7f9ac46d6412d370f98a79ab31384ff0b0f0b09a4cac73165b 1.6s done
Jan 23 12:20:19 PM  #6 DONE 12.5s
Jan 23 12:20:20 PM  
Jan 23 12:20:20 PM  #6 [builder 1/3] FROM ghcr.io/renderinc/heroku-app-builder:v4-heroku-18@sha256:4f314b7f6d7b299089227a2032b53b8b53010950090367ffb6d647ee9238c5ce
Jan 23 12:20:20 PM  #6 extracting sha256:4f4fb700ef54461cfa02571ae0db9a0dc1e0cdb5577484a6d75e68dc38e8acc1 done
Jan 23 12:20:20 PM  #6 DONE 12.5s
Jan 23 12:20:20 PM  
Jan 23 12:20:20 PM  #8 [builder 2/3] COPY --chown=1000:1000 . /app/
Jan 23 12:20:20 PM  #8 DONE 0.1s
Jan 23 12:20:20 PM  
Jan 23 12:20:20 PM  #9 [builder 3/3] RUN /render/build-scripts/apply-buildpacks.py heroku-22
Jan 23 12:20:20 PM  #9 0.137 Node.js
Jan 23 12:20:20 PM  #9 0.139 fatal: not a git repository (or any of the parent directories): .git
Jan 23 12:20:20 PM  #9 0.503
Jan 23 12:20:20 PM  #9 0.503 -----> Creating runtime environment
Jan 23 12:20:20 PM  #9 0.510
Jan 23 12:20:20 PM  #9 0.511        NPM_CONFIG_LOGLEVEL=error
Jan 23 12:20:20 PM  #9 0.518        NODE_VERBOSE=false
Jan 23 12:20:20 PM  #9 0.518        NODE_ENV=production
Jan 23 12:20:20 PM  #9 0.518        NODE_MODULES_CACHE=true
Jan 23 12:20:20 PM  #9 0.522
Jan 23 12:20:20 PM  #9 0.522 -----> Installing binaries
Jan 23 12:20:20 PM  #9 0.631        engines.node (package.json):  10.16.3
Jan 23 12:20:20 PM  #9 0.631        engines.npm (package.json):   6.11.2
Jan 23 12:20:20 PM  #9 0.631        engines.yarn (package.json):  1.15.2
Jan 23 12:20:20 PM  #9 0.631
Jan 23 12:20:20 PM  #9 0.635        Resolving node version 10.16.3...
Jan 23 12:20:21 PM  #9 1.621        Downloading and installing node 10.16.3...
Jan 23 12:20:24 PM  #9 4.395        Bootstrapping npm 6.11.2 (replacing 6.9.0)...
Jan 23 12:20:33 PM  #9 13.58        npm 6.11.2 installed
Jan 23 12:20:33 PM  #9 13.68        Resolving yarn version 1.15.2...
Jan 23 12:20:34 PM  #9 14.26        Downloading and installing yarn (1.15.2)
Jan 23 12:20:35 PM  #9 15.86        Installed yarn 1.15.2
Jan 23 12:20:37 PM  #9 17.12
Jan 23 12:20:37 PM  #9 17.12 -----> Installing dependencies
Jan 23 12:20:37 PM  #9 17.13        Installing node modules
Jan 23 12:20:51 PM  #9 31.28
Jan 23 12:20:51 PM  #9 31.28        > fsevents@1.2.9 install /app/node_modules/fsevents
Jan 23 12:20:51 PM  #9 31.28        > node install
Jan 23 12:20:51 PM  #9 31.28
Jan 23 12:20:51 PM  #9 31.70
Jan 23 12:20:51 PM  #9 31.70        > core-js@2.6.11 postinstall /app/node_modules/draft-js/node_modules/core-js
Jan 23 12:20:51 PM  #9 31.70        > node -e "try{require('./postinstall')}catch(e){}"
Jan 23 12:20:51 PM  #9 31.70
Jan 23 12:20:52 PM  #9 32.03
Jan 23 12:20:52 PM  #9 32.03        > node-sass@4.13.0 install /app/node_modules/node-sass
Jan 23 12:20:52 PM  #9 32.03        > node scripts/install.js
Jan 23 12:20:52 PM  #9 32.03
Jan 23 12:20:52 PM  #9 32.41        Downloading binary from https://github.com/sass/node-sass/releases/download/v4.13.0/linux-x64-64_binding.node
Jan 23 12:20:53 PM  #9 33.96        Download complete
Jan 23 12:20:53 PM  #9 33.97        Binary saved to /app/node_modules/node-sass/vendor/linux-x64-64/binding.node
Jan 23 12:20:53 PM  #9 34.00        Caching binary to /tmp/npmcache.85dMn/node-sass/4.13.0/linux-x64-64_binding.node
Jan 23 12:20:53 PM  #9 34.04
Jan 23 12:20:54 PM  #9 34.04        > node-sass@4.13.0 postinstall /app/node_modules/node-sass
Jan 23 12:20:54 PM  #9 34.04        > node scripts/build.js
Jan 23 12:20:54 PM  #9 34.04
Jan 23 12:20:54 PM  #9 34.23        Binary found at /app/node_modules/node-sass/vendor/linux-x64-64/binding.node
Jan 23 12:20:54 PM  #9 34.23        Testing binary
Jan 23 12:20:54 PM  #9 34.37        Binary is fine
Jan 23 12:20:54 PM  #9 34.39
Jan 23 12:20:54 PM  #9 34.39        > core-js@3.3.6 postinstall /app/node_modules/core-js
Jan 23 12:20:54 PM  #9 34.39        > node postinstall || echo "ignore"
Jan 23 12:20:54 PM  #9 34.39
Jan 23 12:20:54 PM  #9 34.60        added 1437 packages in 17.014s
Jan 23 12:20:54 PM  #9 34.73
Jan 23 12:20:54 PM  #9 34.73 -----> Build
Jan 23 12:20:54 PM  #9 34.81        Detected both "build" and "heroku-postbuild" scripts
Jan 23 12:20:54 PM  #9 34.88        Running heroku-postbuild
Jan 23 12:20:55 PM  #9 35.23
Jan 23 12:20:55 PM  #9 35.23        > swyle@0.1.0 heroku-postbuild /app
Jan 23 12:20:55 PM  #9 35.23        > yarn build && yarn deploy
Jan 23 12:20:55 PM  #9 35.23
Jan 23 12:20:55 PM  #9 35.51        yarn run v1.15.2
Jan 23 12:20:55 PM  #9 35.56        $ yarn --cwd client install && yarn --cwd client build
Jan 23 12:20:55 PM  #9 35.86        info No lockfile found.
Jan 23 12:20:55 PM  #9 35.87 warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
Jan 23 12:20:55 PM  #9 35.87        [1/4] Resolving packages...
Jan 23 12:20:56 PM  #9 36.52 warning axios@0.19.2: Critical security vulnerability fixed in v0.21.1. For more information, see https://github.com/axios/axios/pull/3410
Jan 23 12:20:58 PM  #9 38.69 warning react-scripts > babel-eslint@10.0.2: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
Jan 23 12:20:59 PM  #9 38.96 warning react-scripts > eslint-loader@2.2.1: This loader has been deprecated. Please use eslint-webpack-plugin
Jan 23 12:20:59 PM  #9 39.08 warning react-scripts > html-webpack-plugin@4.0.0-beta.5: please switch to a stable version
Jan 23 12:20:59 PM  #9 39.26 warning react-scripts > fsevents@2.0.7: "Please update to latest v2.3 or v2.2"
Jan 23 12:21:00 PM  #9 40.61 warning react-scripts > webpack-dev-server > chokidar@2.1.8: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
Jan 23 12:21:00 PM  #9 40.61 warning react-scripts > react-dev-utils > fork-ts-checker-webpack-plugin > chokidar@2.1.8: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
Jan 23 12:21:00 PM  #9 40.62 warning react-scripts > webpack-dev-server > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
Jan 23 12:21:00 PM  #9 40.91 warning react-scripts > babel-jest > @jest/transform > jest-haste-map > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
Jan 23 12:21:01 PM  #9 41.36 warning react-scripts > @svgr/webpack > @svgr/plugin-svgo > svgo@1.3.2: This SVGO version is no longer supported. Upgrade to v2.x.x.
Jan 23 12:21:01 PM  #9 41.85 warning react-scripts > jest-environment-jsdom-fourteen > jsdom > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
Jan 23 12:21:01 PM  #9 41.86 warning react-scripts > jest-environment-jsdom-fourteen > jsdom > w3c-hr-time@1.0.2: Use your platform's native performance.now() and performance.timeOrigin.
Jan 23 12:21:01 PM  #9 41.87 warning react-scripts > jest-environment-jsdom-fourteen > jsdom > request-promise-native@1.0.9: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
Jan 23 12:21:02 PM  #9 42.18 warning react-scripts > workbox-webpack-plugin > workbox-build > @hapi/joi@15.1.1: Switch to 'npm install joi'
Jan 23 12:21:02 PM  #9 42.47 warning react-scripts > webpack-dev-server > sockjs > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
Jan 23 12:21:02 PM  #9 42.47 warning react-scripts > webpack-dev-server > webpack-log > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
Jan 23 12:21:02 PM  #9 42.47 warning react-scripts > jest-environment-jsdom-fourteen > jsdom > request > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
Jan 23 12:21:02 PM  #9 42.49 warning react-scripts > webpack-dev-server > url > querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
Jan 23 12:21:02 PM  #9 42.60 warning react-scripts > webpack > watchpack > watchpack-chokidar2 > chokidar@2.1.8: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
Jan 23 12:21:02 PM  #9 42.74 warning react-scripts > babel-jest > @jest/transform > jest-haste-map > sane@4.1.0: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added
Jan 23 12:21:02 PM  #9 42.84 warning react-scripts > @svgr/webpack > @svgr/plugin-svgo > svgo > stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility
Jan 23 12:21:03 PM  #9 43.29 warning react-scripts > jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
Jan 23 12:21:03 PM  #9 43.29 warning react-scripts > jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > request-promise-native@1.0.9: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
Jan 23 12:21:03 PM  #9 43.29 warning react-scripts > jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > w3c-hr-time@1.0.2: Use your platform's native performance.now() and performance.timeOrigin.
Jan 23 12:21:03 PM  #9 43.35 warning react-scripts > jest-environment-jsdom-fourteen > jsdom > request > har-validator@5.1.5: this library is no longer supported
Jan 23 12:21:03 PM  #9 43.40 warning react-scripts > postcss-preset-env > postcss-color-functional-notation > postcss-values-parser > flatten@1.0.3: flatten is deprecated in favor of utility frameworks such as lodash.
Jan 23 12:21:03 PM  #9 43.60 warning react-scripts > optimize-css-assets-webpack-plugin > cssnano > cssnano-preset-default > postcss-svgo > svgo@1.3.2: This SVGO version is no longer supported. Upgrade to v2.x.x.
Jan 23 12:21:03 PM  #9 43.60 warning react-scripts > resolve-url-loader > rework > css > source-map-resolve@0.5.3: See https://github.com/lydell/source-map-resolve#deprecated
Jan 23 12:21:03 PM  #9 43.60 warning react-scripts > webpack > micromatch > snapdragon > source-map-resolve@0.5.3: See https://github.com/lydell/source-map-resolve#deprecated
Jan 23 12:21:03 PM  #9 43.61 warning react-scripts > resolve-url-loader > rework > css > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
Jan 23 12:21:03 PM  #9 43.61 warning react-scripts > resolve-url-loader > rework > css > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
Jan 23 12:21:03 PM  #9 43.75 warning react-scripts > workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/address@2.1.4: Moved to 'npm install @sideway/address'
Jan 23 12:21:03 PM  #9 43.75 warning react-scripts > workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
Jan 23 12:21:03 PM  #9 43.76 warning react-scripts > workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
Jan 23 12:21:03 PM  #9 43.77 warning react-scripts > workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
Jan 23 12:21:03 PM  #9 43.77 warning react-scripts > workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/topo > @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
Jan 23 12:21:04 PM  #9 44.34 warning react-scripts > jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > left-pad@1.3.0: use String.prototype.padStart()
Jan 23 12:21:04 PM  #9 44.47 warning react-scripts > resolve-url-loader > rework > css > source-map-resolve > source-map-url@0.4.1: See https://github.com/lydell/source-map-url#deprecated
Jan 23 12:21:04 PM  #9 44.47 warning react-scripts > resolve-url-loader > rework > css > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
Jan 23 12:21:04 PM  #9 44.51 warning react-scripts > workbox-webpack-plugin > workbox-build > strip-comments > babel-plugin-transform-object-rest-spread > babel-runtime > core-js@2.6.12: core-js@<3.23.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Some versions have web compatibility issues. Please, upgrade your dependencies to the actual version of core-js.
Jan 23 12:21:04 PM  #9 45.03        [2/4] Fetching packages...
Jan 23 12:23:26 PM  #9 186.9        info fsevents@2.0.7: The platform "linux" is incompatible with this module.
Jan 23 12:23:26 PM  #9 186.9        info "fsevents@2.0.7" is an optional dependency and failed compatibility check. Excluding it from installation.
Jan 23 12:23:26 PM  #9 186.9        info fsevents@1.2.13: The platform "linux" is incompatible with this module.
Jan 23 12:23:26 PM  #9 186.9        info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
Jan 23 12:23:26 PM  #9 186.9        info fsevents@2.3.2: The platform "linux" is incompatible with this module.
Jan 23 12:23:26 PM  #9 186.9        info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
Jan 23 12:23:26 PM  #9 186.9        [3/4] Linking dependencies...
Jan 23 12:23:26 PM  #9 186.9 warning " > graphql-ruby-client@1.11.4" has unmet peer dependency "@apollo/client@>=3.3.6".
Jan 23 12:23:26 PM  #9 186.9 warning " > react-apollo@3.1.5" has unmet peer dependency "@types/react@^16.8.0".
Jan 23 12:23:26 PM  #9 186.9 warning "react-apollo > @apollo/react-hooks@3.1.5" has unmet peer dependency "@types/react@^16.8.0".
Jan 23 12:23:26 PM  #9 186.9 warning "react-apollo > @apollo/react-common@3.1.4" has unmet peer dependency "@types/react@^16.8.0".
Jan 23 12:23:27 PM  #9 186.9 warning "react-apollo > @apollo/react-common@3.1.4" has unmet peer dependency "apollo-utilities@^1.3.2".
Jan 23 12:23:27 PM  #9 186.9 warning "react-apollo > @apollo/react-components@3.1.5" has unmet peer dependency "@types/react@^16.8.0".
Jan 23 12:23:27 PM  #9 186.9 warning "react-apollo > @apollo/react-components@3.1.5" has unmet peer dependency "apollo-cache@^1.3.2".
Jan 23 12:23:27 PM  #9 186.9 warning "react-apollo > @apollo/react-components@3.1.5" has unmet peer dependency "apollo-utilities@^1.3.2".
Jan 23 12:23:27 PM  #9 186.9 warning "react-apollo > @apollo/react-hoc@3.1.5" has unmet peer dependency "@types/react@^16.8.0".
Jan 23 12:23:27 PM  #9 186.9 warning "react-scripts > @typescript-eslint/parser@1.13.0" has incorrect peer dependency "eslint@^5.0.0".
Jan 23 12:23:27 PM  #9 186.9 warning "react-scripts > eslint-config-react-app@5.2.1" has incorrect peer dependency "@typescript-eslint/eslint-plugin@2.x".
Jan 23 12:23:27 PM  #9 186.9 warning "react-scripts > eslint-config-react-app@5.2.1" has incorrect peer dependency "@typescript-eslint/parser@2.x".
Jan 23 12:23:27 PM  #9 186.9 warning "react-scripts > @typescript-eslint/eslint-plugin@1.13.0" has incorrect peer dependency "eslint@^5.0.0".
Jan 23 12:23:27 PM  #9 186.9 warning "react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.21.0" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
Jan 23 12:24:22 PM  #9 242.1        [4/4] Building fresh packages...
Jan 23 12:24:24 PM  #9 244.2        success Saved lockfile.
Jan 23 12:24:24 PM  #9 244.8        $ react-scripts build
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 There might be a problem with the project dependency tree.
Jan 23 12:24:25 PM  #9 245.0 It is likely not a bug in Create React App, but something you need to fix locally.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 The react-scripts package provided by Create React App requires a dependency:
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0   "webpack": "4.39.1"
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 Don't try to install it manually: your package manager does it automatically.
Jan 23 12:24:25 PM  #9 245.0 However, a different version of webpack was detected higher up in the tree:
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0   /app/node_modules/webpack (version: 4.41.2)
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 Manually installing incompatible versions is known to cause hard-to-debug issues.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 If you would prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
Jan 23 12:24:25 PM  #9 245.0 That will permanently disable this message but you might encounter other issues.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 To fix the dependency tree, try following the steps below in the exact order:
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0   1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
Jan 23 12:24:25 PM  #9 245.0   2. Delete node_modules in your project folder.
Jan 23 12:24:25 PM  #9 245.0   3. Remove "webpack" from dependencies and/or devDependencies in the package.json file in your project folder.
Jan 23 12:24:25 PM  #9 245.0   4. Run npm install or yarn, depending on the package manager you use.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 In most cases, this should be enough to fix the problem.
Jan 23 12:24:25 PM  #9 245.0 If this has not helped, there are a few other things you can try:
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0   5. If you used npm, install yarn (http://yarnpkg.com/) and repeat the above steps with it instead.
Jan 23 12:24:25 PM  #9 245.0      This may help because npm has known issues with package hoisting which may get resolved in future versions.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0   6. Check if /app/node_modules/webpack is outside your project directory.
Jan 23 12:24:25 PM  #9 245.0      For example, you might have accidentally installed something in your home folder.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0   7. Try running npm ls webpack in your project folder.
Jan 23 12:24:25 PM  #9 245.0      This will tell you which other package (apart from the expected react-scripts) installed webpack.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
Jan 23 12:24:25 PM  #9 245.0 That would permanently disable this preflight check in case you want to proceed anyway.
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 P.S. We know this message is long but please read the steps above :-) We hope you find them helpful!
Jan 23 12:24:25 PM  #9 245.0
Jan 23 12:24:25 PM  #9 245.0 error Command failed with exit code 1.
Jan 23 12:24:25 PM  #9 245.0        info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
Jan 23 12:24:25 PM  #9 245.1 error Command failed with exit code 1.
Jan 23 12:24:25 PM  #9 245.1        info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
Jan 23 12:24:25 PM  #9 245.1 npm ERR! code ELIFECYCLE
Jan 23 12:24:25 PM  #9 245.1 npm ERR! errno 1
Jan 23 12:24:25 PM  #9 245.1 npm ERR! swyle@0.1.0 heroku-postbuild: `yarn build && yarn deploy`
Jan 23 12:24:25 PM  #9 245.1 npm ERR! Exit status 1
Jan 23 12:24:25 PM  #9 245.1 npm ERR!
Jan 23 12:24:25 PM  #9 245.1 npm ERR! Failed at the swyle@0.1.0 heroku-postbuild script.
Jan 23 12:24:25 PM  #9 245.1 npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Jan 23 12:24:25 PM  #9 245.1
Jan 23 12:24:25 PM  #9 245.1 npm ERR! A complete log of this run can be found in:
Jan 23 12:24:25 PM  #9 245.1 npm ERR!     /tmp/npmcache.85dMn/_logs/2023-01-23T20_24_25_023Z-debug.log
Jan 23 12:24:25 PM  #9 245.2
Jan 23 12:24:25 PM  #9 245.2 -----> Build failed
Jan 23 12:24:25 PM  #9 245.5
Jan 23 12:24:25 PM  #9 245.5        We're sorry this build is failing! You can troubleshoot common issues here:
Jan 23 12:24:25 PM  #9 245.5        https://devcenter.heroku.com/articles/troubleshooting-node-deploys
Jan 23 12:24:25 PM  #9 245.5
Jan 23 12:24:25 PM  #9 245.5        If you're stuck, please submit a ticket so we can help:
Jan 23 12:24:25 PM  #9 245.5        https://help.heroku.com/
Jan 23 12:24:25 PM  #9 245.5
Jan 23 12:24:25 PM  #9 245.5        Love,
Jan 23 12:24:25 PM  #9 245.5        Heroku
Jan 23 12:24:25 PM  #9 245.5
Jan 23 12:24:25 PM  #9 245.5  - heroku/nodejs
Jan 23 12:24:25 PM  #9 245.5     - preinstalled buildpack detected
Jan 23 12:24:25 PM  #9 245.5  - heroku/ruby
Jan 23 12:24:25 PM  #9 245.5     - preinstalled buildpack detected
Jan 23 12:24:25 PM  #9 245.5  - 2 buildpacks resolved.
Jan 23 12:24:25 PM  #9 245.5     - /render-build/cache/cache/heroku/nodejs
Jan 23 12:24:25 PM  #9 245.5       - bin/detect OK
Jan 23 12:24:25 PM  #9 245.5       - cmd: STACK=heroku-22 SOURCE_VERSION=$(git -C '/app' rev-parse --verify HEAD) /render-build/cache/cache/heroku/nodejs/bin/compile '/app' '/render-build/cache' '/render-build/env'
Jan 23 12:24:25 PM  #9 245.5 Traceback (most recent call last):
Jan 23 12:24:25 PM  #9 245.5   File "/render/build-scripts/apply-buildpacks.py", line 167, in <module>
Jan 23 12:24:25 PM  #9 245.5     raise Exception(err_msg)
Jan 23 12:24:25 PM  #9 245.5 Exception: bin/compile failed for '/render-build/cache/cache/heroku/nodejs'.
Jan 23 12:24:26 PM  #9 ERROR: process "/bin/bash -c /render/build-scripts/apply-buildpacks.py ${HEROKU_STACK}" did not complete successfully: exit code: 1
Jan 23 12:24:26 PM  ------
Jan 23 12:24:26 PM   > [builder 3/3] RUN /render/build-scripts/apply-buildpacks.py heroku-22:
Jan 23 12:24:26 PM  #9 245.5  - heroku/ruby
Jan 23 12:24:26 PM  #9 245.5     - preinstalled buildpack detected
Jan 23 12:24:26 PM  #9 245.5  - 2 buildpacks resolved.
Jan 23 12:24:26 PM  #9 245.5     - /render-build/cache/cache/heroku/nodejs
Jan 23 12:24:26 PM  #9 245.5       - bin/detect OK
Jan 23 12:24:26 PM  #9 245.5       - cmd: STACK=heroku-22 SOURCE_VERSION=$(git -C '/app' rev-parse --verify HEAD) /render-build/cache/cache/heroku/nodejs/bin/compile '/app' '/render-build/cache' '/render-build/env'
Jan 23 12:24:26 PM  #9 245.5 Traceback (most recent call last):
Jan 23 12:24:26 PM  #9 245.5   File "/render/build-scripts/apply-buildpacks.py", line 167, in <module>
Jan 23 12:24:26 PM  #9 245.5     raise Exception(err_msg)
Jan 23 12:24:26 PM  #9 245.5 Exception: bin/compile failed for '/render-build/cache/cache/heroku/nodejs'.
Jan 23 12:24:26 PM  ------
Jan 23 12:24:26 PM  Dockerfile.render:25
Jan 23 12:24:26 PM  --------------------
Jan 23 12:24:26 PM    23 |     # in place. We then run the apply-buildpacks.py script here because, unlike our
Jan 23 12:24:26 PM    24 |     # `v2` image, this allows us to expose build-time env vars to your app.
Jan 23 12:24:26 PM    25 | >>> RUN /render/build-scripts/apply-buildpacks.py ${HEROKU_STACK}
Jan 23 12:24:26 PM    26 |
Jan 23 12:24:26 PM    27 |     # We strongly recommend that you package a Procfile with your application, but
Jan 23 12:24:26 PM  --------------------
Jan 23 12:24:26 PM  error: failed to solve: process "/bin/bash -c /render/build-scripts/apply-buildpacks.py ${HEROKU_STACK}" did not complete successfully: exit code: 1