Installing requirements.txt keeps failing due to outdated pip version help!

When running pip install requirements.txt it keeps failing telling me that my pip version is outdated that newer releases are available please how do I fix that

Hi there,

I’ve replied to the ticket you also opened, but to share the solution with the community, I’ll post the same response here:

The pip version is not the error. The error in your build logs is:

ERROR: Could not find a version that satisfies the requirement Django==4.1.4 (from -r requirements.txt (line 4))

[Django 4.1.4 requires at least Python 3.8(https://pypi.org/project/Django/). The Render default is 3.7.10. You’ll need to specify a Python Version, it’s probably best to use the same version you develop on locally.

As an aside, if you did want to upgrade pip, the command is included in the screenshot you shared, you could update your Build Command, for example:

pip install --upgrade pip && pip install -r requirements.txt

Hope that helps

Kind regards

Alan

Set an environment variable (“Environments” page on your service) called PYTHON_VERSION. With a value matching the Python version you use locally.

Alan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.