I can not add app level authorization requirement ?!

I’m trying to add app-level authorization for a web-service running on Node

Before merge from Github and deployment takes places, I click on “Advanced” and add the Environment Variables

For example:

Key: APPNAME_PASSWORD. VALUE: example_password456


Once the Webapp is deployed and live , when I click the link:

https://example_appname-w11.onrender.com - I don’t need to enter any credentials.

I’ve tried with different browsers , incognito mode as well as using a different IP (VPN) with a different browser.

Tried restarting the service etc. …

No matter what I do, the deployed Webapp is always accessible to anyone without password/user name request.

What am I doing wrong?


It’s hard to provide advice when talking in generalities. However, this currently sounds like a code/config issue

Please could you share some specific details of the issue you are experiencing that may help us troubleshoot it with you, e.g. any logs/errors/output, specific URLs, service name/ID, reproduction steps, etc.

If you don’t want to share these details on the community forum, please feel free to raise a ticket from the “Help” or “Contact Support” links at the bottom of the Dashboard.


Thanks Alan.

I’ll raise a ticket.

Have a great day.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.