Help with this: "error Your lockfile needs to be updated, but yarn was run with `--frozen-lockfile`"

Hello hello, I keep getting this error in my build, I’m looking for help about how to debug it.

Error message:
error Your lockfile needs to be updated, but yarn was run with --frozen-lockfile

  • My repo is even public if you wanna take a look GitHub - giovanemachado/castle_age: Castle Age frontend..
  • Building command I’m using is: yarn install --frozen-lockfile; yarn build; I tried removing the frozen flag, even tried to add something random (to cause an error) but seems to be not reaching this command.
  • I’m using next, and creating from dashboard as a Static Service.
  • I tried creating a new dashboard (thought was something related to a cache somewhere) but got the same error.
  • In localhost there are no errors.
  • I tried deploying last commit, and also clean cache + deploy.
  • Locally I deleted my yarn lock, then recreated it sometimes, but no luck.

It works if creating a webservice from dashboard instead of static site. That’s it? I’m almost sure it worked as static site previously.


I’ve replied to the ticket you also opened. I’ll add the same response here:

Static Sites will try and detect and auto-install dependencies. If you want to disable auto dependency installation on a Static Site, so that it only runs your Build Command, you can do so by following the docs here:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.