Build failed - node is incompatible

Hi together,
my build failed but local (on github) is ok.

These are details:

Feb 2 11:20:32 AM ==> Cloning from
Feb 2 11:20:33 AM ==> Checking out commit 457d536351149d18afe3d9e1cd0d644ccaec375d in branch main
Feb 2 11:20:34 AM ==> Downloading cache…
Feb 2 11:20:43 AM ==> Transferred 4.6MB in 8s. Extraction took 0s.
Feb 2 11:20:44 AM ==> Running build command ‘yarn’…
Feb 2 11:20:44 AM yarn install v1.22.5
Feb 2 11:20:44 AM info No lockfile found.
Feb 2 11:20:44 AM warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
Feb 2 11:20:44 AM [1/4] Resolving packages…
Feb 2 11:20:51 AM [2/4] Fetching packages…
Feb 2 11:20:54 AM error parser@0.1.4: The engine “node” is incompatible with this module. Expected version “0.4-0.9”. Got “14.17.0”
Feb 2 11:20:54 AM error Found incompatible module.
Feb 2 11:20:54 AM info Visit yarn install | Yarn for documentation about this command.
Feb 2 11:20:54 AM ==> Build failed :disappointed:
Feb 2 11:20:54 AM ==> Generating container image from build. This may take a few minutes…

I don’t understand what is the problem. Must I install yarn?

In the previous push, I didn’t have a problem.

I am having a similar problem, I think you need to use yarn for build to be succesful.

But if you use yarn then deployment fails…

Yes, deployment fails again.

I tried these things:

  • install yarn

  • yarn install --ignore-engines

  • update node to the ultimate version

In all cases, the issue isn’t resolved.


The error points to the parser package. error parser@0.1.4.

This package appears to be 10 years old:

And it’s own package.json requires an ancient version of Node :

Which is also shown in the error: Expected version “0.4-0.9”.

You don’t appear to use yarn locally as yarn is warning there is no lockfile: info No lockfile found.

If use npm locally, use npm to install/build your app on Render. But the main issue seems to be that the very old package has a massively outdated Node version requirement.


Hi Alan,
thanks, I solved it by deleting the old package.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.