Gunicorn app:app doesn't work

I checked if I have multiple requirements.txt and tried to change the start command to this: export PATH=$PATH:/usr/local/python3/bin && pip install gunicorn && gunicorn app:app according to this discussion: Bash: gunicorn: command not found. But nothing seemed to work (also I’am new to linux mint so it could be that I left out something). The log with export PATH=$PATH:/usr/local/python3/bin && pip install gunicorn && gunicorn app:app :

You shouldn’t be installing dependencies as part of your Start Command, the Build Command should build all dependencies and set up any aspect of your application so that it starts via the Start Command alone.

Well I tried gunicorn app:app so what do you suggest? What do I use instead?

Why isn’t gunicorn being installed via the Build Command?

thx, I tried like that, now there is a different error, It doesn’t find openpyxl although I have it in the requirements.txt

That’t the requirements.txt:

Could you post the whole deployment log? That is the error, but the context leading up to it matters too.

do you need the build log or the entire log?

It’s not clear to me what you mean by the build log versus entire log. I need whatever is relevant to the cause of the failure. If you don’t know what that is, it’s probably the entire log.

This is the start of the entire log:

and this is the part where it installs openpyxl:

After it yields the error i get this (With a lot more other info about where the error occured):

When you created this service, it was detected as or you set it up as a “Node” app. If you create a new service and set it to be a Python app, you should have dramatically fewer issues.