gRPC client dial up error

Hi, I’ve been trying to setup a gRPC server but I’ve ran into some issues connecting from the client. I did a pretty simple example on Go that already works on my localhost when dialing up from the client app, but once I try to dial up against the deployed server I can never get a response, it either times out or get me some rpc error: code = Unavailable desc = connection closed before server preface received

As on now my app is binding 0.0.0.0 as the host and 8080 as the port (first I had localhost as the hostname, but I read in this post that the address 0.0.0.0 should be used instead.) both hostnames worked with the port mentioned above, at least the deployment says it succeed but whenever I try dialing up myapp.onrender.com no mater which port I use it will never succeed. I tried 8080 since is the one I used on my variables, also tried 80, 443 and 1000(because somewhere on the docs I saw that that was the default) with no luck. I am not sure what I’m missing here or if it is even possible to have a grpc client exposed like that.

I think its important to mention that I’m not using any dockerfiles, just the bare minimum I saw on the docs using the default command to build and run the binary.

Thanks in advance!

We only accept inbound requests via HTTP to port 443 so it’s only possible if you can use gRPC over HTTP here,

Regards,

John B

If I try to connect from my client to the remote server via port 443 I still get an error, the server seems to be bounding well to the host and port but the client can’t never reach or get any response even with port 443