Getting Seg Fault During Web Service Build Process

I’m getting this error:

Oct 10 10:38:25 PM  ==> Cloning from
Oct 10 10:38:25 PM  ==> Checking out commit 6f18a56dc04f880b3fa41c737c3d5847daa47c71 in branch master
Oct 10 10:38:28 PM  ==> Downloading cache...
Oct 10 10:38:40 PM  ==> Transferred 35MB in 8s. Extraction took 2s.
Oct 10 10:38:41 PM  ==> Using Node version 18.18.1 via environment variable NODE_VERSION
Oct 10 10:38:41 PM  ==> Docs on specifying a Node version:
Oct 10 10:38:41 PM  ==> Running build command 'npm run install-server'...
Oct 10 10:38:41 PM line 33:    45 Segmentation fault      bash -c -- "$USER_BUILD_CMD"
Oct 10 10:38:41 PM  ==> Build failed 😞

when I try to push a commit to my connected repository, though I’m only pushing the client part of the code which should only be redeploying the static site. The static site successfully gets redeployed, but the web service fails with a seg fault on the build part.

Here’s a link to the repository.

What do I do to solve this?

Same here!

Hi there,

Sorry you’re running into these issues. We are aware of intermittent issues downloading Node Runtime environments which can cause this type of error. I’ll flag this with the team so they’re aware it’s impacting both of you.

Typically builds will see this issue for a short time and it will resolve itself. Just for the time being, the best approach is to simply wait a bit and try redeploying.

Thanks for your patience as we continue to work on a resolution for this issue.



Hi there,

Quick follow up on. Could you try a Manual Deploy, selecting the Clear build cache & deploy option.

This has worked for few other users who have recently upgraded to Node 18.18.1.

Give that a try and let me know how it goes.



Wow Thanks so much for this. I just tried clearing build cache and it worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.