Flask app routes not loading except the "/" one

I have this web-service where I have two routes, “/” and “/search” but for some reason, the search route is not working only!!!
I tried deploying the demo flask project from render docs and added the same route method to it, and it worked there but for my project that route is not working only. I have my project submission tomorrow. Please help me ASAP!!!

This is the route I am concerned with. Everything is working absolutely fine on my local machine fyi.


It looks like the /search route is working but it’s timing out:

Oct 25 03:53:34 PM search route triggered for: helloOct 25 03:53:35 PM [2023-10-25 12:53:35 +0000] [41] [WARNING] Worker with pid 51 was terminated due to signal 9Oct 25 03:53:35 PM [2023-10-25 12:53:35 +0000] [52] [INFO] Booting worker with pid: 52

I would advise trying to add a timeout value to your gunicorn start command: https://docs.gunicorn.org/en/stable/settings.html#timeout although a simple search like this shouldn’t take more than a second so I’m unsure why this endpoint is timing out.

Render Support, UTC+3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.