ERROR: No matching distribution found

Hello, I am trying to deploy my github repository (here), but it keeps failing. According to the logs, this is the error:

Collecting tensorboard-data-server==0.7.2
  Downloading tensorboard_data_server-0.7.2-py3-none-any.whl (2.4 kB)
Collecting tensorflow==2.14.0
  Downloading tensorflow-2.14.0-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (489.8 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 489.8/489.8 MB 1.1 MB/s eta 0:00:00
Collecting tensorflow-estimator==2.14.0
  Downloading tensorflow_estimator-2.14.0-py2.py3-none-any.whl (440 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 440.7/440.7 kB 3.8 MB/s eta 0:00:00
ERROR: Could not find a version that satisfies the requirement tensorflow-intel==2.14.0 (from versions: 0.0.1)
ERROR: No matching distribution found for tensorflow-intel==2.14.0

Everything was installing, but it stops at tensorflow-intel==2.14.0, which is a slightly outdated version of tensorflow. I then set the Python version through the environment tab to 3.10.9, which is the version of my Python, but I still received the same error. What should I do? I hope you can enlighten me.

Happy Holidays!

Update: I found the correct version of Python by checking my virtual environment, it is 3.10.11 and changed it in the environment variables accordingly. I also updated the pip version to 23.3.1, which is the same as the pip version in my virtual environment. Unfortunately, it still gave the same error


I see that you’ve already initiated a support ticket with us. To avoid any confusion or duplicate efforts, let’s continue the conversation there

Render Support, UTC+3

Got it, thanks, Jeremy!

Also, to those who may have this problem in the future, this happened to me because I built a Flask webapp on Windows when Render uses Linux. Linux doesn’t have tensorflow-intel.

To further add, free tier isn’t enough to test ML Web services

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.