Environment variable changes aren't picked up on new deployments

On a free web service instance, when I change the environment variables, the server does not redeploy, nor does it pick up the new variables even when I manually redeploy.

I have tried editing both the main environment variables settings and the secret files. Neither works.

I have also tried a full server restart, and this also doesn’t work.

Another odd situation I encountered, was when I go to create and all-new web service, when I go to save a new “secret file” in the advanced settings, as soon as I save the file, it immediately deploys the server and doesn’t let me mess with any of the other settings. It seems like after I save the file, it shouldn’t deploy yet and allow me to set other settings first.

Hi Alan.

I wasn’t able to reproduce your first issue. I started a new free web service using Render’s flask-hello-word repo. I added + updated an environment variable in Environment > Environment Variables, and Render triggered a new Deploy event both times with the following message: Environment updated.

So, this may be an issue with your browser, your Render service instance’s build cache, or something else.

Hi, the redeploy on env change did end up working again (first issue) the next day. I will try clearing my cache if this happens again. Odd thing was that it did save the .env variables in the settings, however it didn’t deploy, and even on redeploy the server wasn’t picking up the new .env variables even though they were saved. This was on a newly created free instance, so I don’t know if that would help reproduce. Thank you!

1 Like

Hi @alanhett,

We’ve confirmed there was an issue on our end with env var updates not triggering deploys. We’re sorry about that - our engineering team has applied a fix for this.

Let me know if you run into any further issues.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.