Elastic Search timeout

I am trying to set up elastic search at my firm with Render and Django, I set up elastic search as directed here
I am currently trying to index records in our db for elastic search. To index all records, I have to run a
./manage.py search_index --rebuild once to index all existing records in our db.Here are the issues,

  • It takes too long to index the records, (This might be related to my setup, see setup here)
  • because the command takes too long, I have to keep the shell open for hours and make sure my internet is stable. I have made tried this several times on some occasions the shell returns Killed, or stops running because my internet went out.

Is there a way to run this command and have it run in the background irrespective of the state of the shell on the dashboard?
is there an issue with my setup on render or django-elasticsearch-dsl?

Hi @scottf, welcome to the Render community!

I took a look at the documentation for Index — django-elasticsearch-dsl 7.1.1 documentation and it looks like you can run that command with the -parallel flag to speed up the indexing process. If that doesn’t work, you can try creating a cron job (which will run a linux command) and trigger it once to do the indexing.