Deployment failed for Community.Talk-Staind

Hello, for the past 2 days I’ve been trying to upload a GitHub directory to create a Discourse site! The first 2 times I uploaded it, it failed because I had mistyped the run command! Recently, I’ve been attempting to upload it multiple times and it just failed again! Showing this response in the “events” section of my dashboard

What the hell does the error code “127” mean? My guess is that it means “PROXY_AUTH_REQUESTED” (though that’s a google chrome error, and that’s probably not what it means)! More importantly, how do I fix the issue?

By the way, the link to my GitHub directory that I’m trying to upload is

I almost feel like this is an issue with the GitHub project itself (cause I don’t know how to create a run command within GitHub, cause I’ve only used it for 2 days with no previous coding experience!)

Either way, can someone please tell me how to fix this?

Alright, I’ve just changed the run command to see if the cause was as I suspected (a mistyped run command)! I’ll provide an update once the deployment completes!

Damn, It failed again! Here’s the logs from deployment

Dec 17 01:49:14 PM  ==> Cloning from https://github.com/Github2503/Talk-Staind...
Dec 17 01:49:18 PM  ==> Checking out commit 078696ca7f0843805207d29b8eb8d2a8314b6246 in branch main
Dec 17 01:49:32 PM  ==> Downloading cache...
Dec 17 01:49:47 PM  ==> Downloaded 330MB in 5s. Extraction took 8s.
Dec 17 01:49:49 PM  ==> Detected Node version 17.2.0
Dec 17 01:49:50 PM  ==> Running build command 'bundle install'...
Dec 17 01:49:52 PM  Using rake 13.0.6
Dec 17 01:49:52 PM  Using concurrent-ruby 1.1.9
Dec 17 01:49:52 PM  Using i18n 1.8.11
Dec 17 01:49:52 PM  Using minitest 5.14.4
Dec 17 01:49:52 PM  Using tzinfo 2.0.4
Dec 17 01:49:52 PM  Using zeitwerk 2.5.1
Dec 17 01:49:52 PM  Using activesupport 6.1.4.1
Dec 17 01:49:52 PM  Using builder 3.2.4
Dec 17 01:49:52 PM  Using erubi 1.10.0
Dec 17 01:49:52 PM  Using racc 1.6.0
Dec 17 01:49:52 PM  Using nokogiri 1.12.5 (x86_64-linux)
Dec 17 01:49:52 PM  Using rails-dom-testing 2.0.3
Dec 17 01:49:52 PM  Using crass 1.0.6
Dec 17 01:49:52 PM  Using loofah 2.13.0
Dec 17 01:49:52 PM  Using rails-html-sanitizer 1.4.2
Dec 17 01:49:52 PM  Using actionview 6.1.4.1
Dec 17 01:49:52 PM  Using rack 2.2.3
Dec 17 01:49:52 PM  Using rack-test 1.1.0
Dec 17 01:49:52 PM  Using actionpack 6.1.4.1
Dec 17 01:49:52 PM  Using globalid 1.0.0
Dec 17 01:49:52 PM  Using activejob 6.1.4.1
Dec 17 01:49:52 PM  Using mini_mime 1.1.2
Dec 17 01:49:52 PM  Using mail 2.8.0.edge from https://github.com/discourse/mail.git
Dec 17 01:49:52 PM  Using actionmailer 6.1.4.1
Dec 17 01:49:52 PM  Using actionview_precompiler 0.2.3
Dec 17 01:49:52 PM  Using activemodel 6.1.4.1
Dec 17 01:49:52 PM  Using active_model_serializers 0.8.4
Dec 17 01:49:52 PM  Using activerecord 6.1.4.1
Dec 17 01:49:52 PM  Using public_suffix 4.0.6
Dec 17 01:49:52 PM  Using addressable 2.8.0
Dec 17 01:49:52 PM  Using aws-eventstream 1.2.0
Dec 17 01:49:52 PM  Using aws-partitions 1.516.0
Dec 17 01:49:52 PM  Using aws-sigv4 1.4.0
Dec 17 01:49:52 PM  Using jmespath 1.4.0
Dec 17 01:49:52 PM  Using aws-sdk-core 3.121.2
Dec 17 01:49:52 PM  Using aws-sdk-kms 1.44.0
Dec 17 01:49:52 PM  Using aws-sdk-s3 1.96.1
Dec 17 01:49:52 PM  Using aws-sdk-sns 1.46.0
Dec 17 01:49:52 PM  Using ember-source 2.18.2
Dec 17 01:49:52 PM  Using execjs 2.8.1
Dec 17 01:49:52 PM  Using barber 0.12.2
Dec 17 01:49:52 PM  Using msgpack 1.4.2
Dec 17 01:49:52 PM  Using bootsnap 1.9.3
Dec 17 01:49:52 PM  Using bundler 2.2.26
Dec 17 01:49:52 PM  Using byebug 11.1.3
Dec 17 01:49:52 PM  Using cbor 0.5.9.6
Dec 17 01:49:52 PM  Using chunky_png 1.4.0
Dec 17 01:49:52 PM  Using coderay 1.1.3
Dec 17 01:49:52 PM  Using colored2 3.1.2
Dec 17 01:49:52 PM  Using connection_pool 2.2.5
Dec 17 01:49:52 PM  Using ipaddr 1.2.3
Dec 17 01:49:52 PM  Using openssl 2.2.1
Dec 17 01:49:52 PM  Using openssl-signature_algorithm 1.1.1
Dec 17 01:49:52 PM  Using cose 1.2.0
Dec 17 01:49:52 PM  Using cppjieba_rb 0.3.3
Dec 17 01:49:52 PM  Using css_parser 1.11.0
Dec 17 01:49:52 PM  Using diffy 3.4.0
Dec 17 01:49:52 PM  Using ember-data-source 3.0.2
Dec 17 01:49:52 PM  Using sprockets 3.7.2
Dec 17 01:49:52 PM  Using ember-handlebars-template 0.8.0
Dec 17 01:49:52 PM  Using method_source 1.0.0
Dec 17 01:49:52 PM  Using thor 1.1.0
Dec 17 01:49:52 PM  Using railties 6.1.4.1
Dec 17 01:49:52 PM  Using jquery-rails 4.4.0
Dec 17 01:49:52 PM  Using discourse-ember-rails 0.18.6
Dec 17 01:49:52 PM  Using discourse-ember-source 3.12.2.3
Dec 17 01:49:52 PM  Using discourse-fonts 0.0.9
Dec 17 01:49:52 PM  Using regexp_parser 2.2.0
Dec 17 01:49:52 PM  Using ecma-re-validator 0.3.0
Dec 17 01:49:52 PM  Using email_reply_trimmer 0.1.13
Dec 17 01:49:52 PM  Using excon 0.89.0
Dec 17 01:49:52 PM  Using exifr 1.3.9
Dec 17 01:49:52 PM  Using faraday-em_http 1.0.0
Dec 17 01:49:52 PM  Using faraday-em_synchrony 1.0.0
Dec 17 01:49:52 PM  Using faraday-excon 1.1.0
Dec 17 01:49:52 PM  Using faraday-httpclient 1.0.1
Dec 17 01:49:52 PM  Using faraday-net_http 1.0.1
Dec 17 01:49:52 PM  Using faraday-net_http_persistent 1.2.0
Dec 17 01:49:52 PM  Using faraday-patron 1.0.0
Dec 17 01:49:52 PM  Using faraday-rack 1.0.0
Dec 17 01:49:52 PM  Using multipart-post 2.1.1
Dec 17 01:49:52 PM  Using ruby2_keywords 0.0.5
Dec 17 01:49:52 PM  Using faraday 1.8.0
Dec 17 01:49:52 PM  Using fast_blank 1.0.1
Dec 17 01:49:52 PM  Using fast_xs 0.8.0
Dec 17 01:49:52 PM  Using fastimage 2.2.5
Dec 17 01:49:52 PM  Using ffi 1.15.4
Dec 17 01:49:52 PM  Using fspath 3.1.2
Dec 17 01:49:52 PM  Using gc_tracer 1.5.1
Dec 17 01:49:52 PM  Using guess_html_encoding 0.0.11
Dec 17 01:49:52 PM  Using hana 1.3.7
Dec 17 01:49:52 PM  Using hashie 4.1.0
Dec 17 01:49:52 PM  Using highline 2.0.3
Dec 17 01:49:52 PM  Using hkdf 0.3.0
Dec 17 01:49:52 PM  Using htmlentities 4.3.4
Dec 17 01:49:52 PM  Using http_accept_language 2.1.1
Dec 17 01:49:52 PM  Using image_size 3.0.1
Dec 17 01:49:52 PM  Using in_threads 1.5.4
Dec 17 01:49:52 PM  Using progress 3.6.0
Dec 17 01:49:52 PM  Using image_optim 0.31.1
Dec 17 01:49:52 PM  Using json 2.6.1
Dec 17 01:49:52 PM  Using uri_template 0.7.0
Dec 17 01:49:52 PM  Using json_schemer 0.2.18
Dec 17 01:49:52 PM  Using jwt 2.3.0
Dec 17 01:49:52 PM  Using kgio 2.11.4
Dec 17 01:49:52 PM  Using libv8-node 16.10.0.0 (x86_64-linux)
Dec 17 01:49:52 PM  Using request_store 1.5.0
Dec 17 01:49:52 PM  Using lograge 0.11.2
Dec 17 01:49:52 PM  Using logstash-event 1.2.02
Dec 17 01:49:52 PM  Using logstash-logger 0.26.1
Dec 17 01:49:52 PM  Using logster 2.10.1
Dec 17 01:49:52 PM  Using lru_redux 1.1.0
Dec 17 01:49:52 PM  Using lz4-ruby 0.3.3
Dec 17 01:49:52 PM  Using maxminddb 0.1.22
Dec 17 01:49:52 PM  Using memory_profiler 1.0.0
Dec 17 01:49:52 PM  Using message_bus 3.3.6
Dec 17 01:49:52 PM  Using mini_racer 0.5.0
Dec 17 01:49:52 PM  Using redis 4.5.1
Dec 17 01:49:52 PM  Using sidekiq 6.3.1
Dec 17 01:49:52 PM  Using mini_scheduler 0.13.0
Dec 17 01:49:52 PM  Using mini_sql 1.1.3
Dec 17 01:49:52 PM  Using mini_suffix 0.3.3
Dec 17 01:49:52 PM  Using multi_json 1.15.0
Dec 17 01:49:52 PM  Using multi_xml 0.6.0
Dec 17 01:49:52 PM  Using mustache 1.1.1
Dec 17 01:49:52 PM  Using nio4r 2.5.8
Dec 17 01:49:52 PM  Using oauth 0.5.8
Dec 17 01:49:52 PM  Using oauth2 1.4.7
Dec 17 01:49:52 PM  Using oj 3.13.2
Dec 17 01:49:52 PM  Using omniauth 1.9.1
Dec 17 01:49:52 PM  Using omniauth-oauth2 1.7.2
Dec 17 01:49:52 PM  Using omniauth-facebook 9.0.0
Dec 17 01:49:52 PM  Using omniauth-github 1.4.0
Dec 17 01:49:52 PM  Using omniauth-google-oauth2 0.8.2
Dec 17 01:49:52 PM  Using omniauth-oauth 1.2.0
Dec 17 01:49:52 PM  Using omniauth-twitter 1.4.0
Dec 17 01:49:52 PM  Using optimist 3.0.1
Dec 17 01:49:52 PM  Using pg 1.2.3
Dec 17 01:49:52 PM  Using pry 0.13.1
Dec 17 01:49:52 PM  Using pry-byebug 3.9.0
Dec 17 01:49:52 PM  Using pry-rails 0.3.9
Dec 17 01:49:52 PM  Using puma 5.5.2
Dec 17 01:49:52 PM  Using r2 0.2.7
Dec 17 01:49:52 PM  Using rack-mini-profiler 2.3.3
Dec 17 01:49:52 PM  Using rack-protection 2.1.0
Dec 17 01:49:52 PM  Using rails_failover 0.7.3
Dec 17 01:49:52 PM  Using rails_multisite 4.0.0
Dec 17 01:49:52 PM  Using raindrops 0.20.0
Dec 17 01:49:52 PM  Using rbtrace 0.4.14
Dec 17 01:49:52 PM  Using rchardet 1.8.0
Dec 17 01:49:52 PM  Using redis-namespace 1.8.1
Dec 17 01:49:52 PM  Using rexml 3.2.5
Dec 17 01:49:52 PM  Using rinku 2.0.6
Dec 17 01:49:52 PM  Using rotp 6.2.0
Dec 17 01:49:52 PM  Using rqrcode_core 1.2.0
Dec 17 01:49:52 PM  Using rqrcode 2.1.0
Dec 17 01:49:52 PM  Using rss 0.2.9
Dec 17 01:49:52 PM  Using rtlit 0.0.5
Dec 17 01:49:52 PM  Using ruby-readability 0.7.0
Dec 17 01:49:52 PM  Using rubyzip 2.3.2
Dec 17 01:49:52 PM  Using sanitize 6.0.0
Dec 17 01:49:52 PM  Using sassc 2.0.1
Dec 17 01:49:52 PM  Using sprockets-rails 3.4.2
Dec 17 01:49:52 PM  Using tilt 2.0.10
Dec 17 01:49:52 PM  Using sassc-rails 2.1.2
Dec 17 01:49:52 PM  Using seed-fu 2.3.9
Dec 17 01:49:52 PM  Using sshkey 2.0.0
Dec 17 01:49:52 PM  Using stackprof 0.2.17
Dec 17 01:49:52 PM  Using uglifier 4.2.0
Dec 17 01:49:52 PM  Using unf_ext 0.0.8
Dec 17 01:49:52 PM  Using unf 0.1.4
Dec 17 01:49:52 PM  Using unicorn 6.0.0
Dec 17 01:49:52 PM  Using webpush 1.1.0
Dec 17 01:49:52 PM  Using xorcist 1.1.2
Dec 17 01:49:52 PM  Bundle complete! 127 Gemfile dependencies, 174 gems now installed.
Dec 17 01:49:52 PM  Gems in the groups 'development' and 'test' were not installed.
Dec 17 01:49:52 PM  Bundled gems are installed into `/opt/render/project/.gems`
Dec 17 01:49:52 PM  ==> Generating container image from build...
Dec 17 01:53:01 PM  ==> Uploading build...
Dec 17 01:54:09 PM  ==> Build successful 🎉
Dec 17 01:54:09 PM  ==> Deploying...

And it also failed with the same error code

So can someone help me! I’ll try one more thing (which likely won’t work) then provide an update!

Ok, I think I get it now! I think I’ll need to adjust a few things before I deploy (as it’s incorrectly set up somewhere)! I’ll try to figure it out myself but if anyone has an idea, please post it here! It will be gladly appreciated!

New idea! Create a new GitHub project, clone all the original files, and then link it to my render account! That might work!

Hey there,

Firstly, please let me remind you that this is a public forum, and whilst you have deleted your posts where you were using profanity, on a public community forum this is not acceptable and will not be tolerated. This is a community-based forum where our community respond to posts as well as being monitored by us at Render. Posts will go unanswered periodically, but being polite doesn’t cost anything and is more conducive to people wanting to help you.

The repo you are deploying there doesn’t look to be the full Discourse codebase. You appear to have zip files contained within the repo which isn’t correct. You should aim have a working application locally before you attempt to deploy it to Render as that is how to development flow works best, once you’ve got that, that is what you add to git and then push to Github for deployment to us. However, this forum isn’t the place to teach these fundamentals

Also please note. From our experience, Discourse is a fairly ‘hungry’ service and probably needs at least our ‘starter plus’ plan which gives it 1GB of RAM to run in,

I hope this helps,
Regards,

John B

So I have to pay to be able to deploy a Discourse site using Render?

Yep, well not pay to deploy, pay to operate. Our free service has lower resources as it’s not intended for general production use (as noted at https://render.com/docs/free) - also depending on the popularity of your community you’d scale up beyond a single service and more performant database to cope with the load.

John B

Well, it’s not going to be a very large fourm so I might be able to use it on a free plan? Also, what does error 127 mean? (you never told me that)

sighs it failed again

The logs are below


Dec 20 12:47:11 PM  ==> Cloning from https://github.com/Github2503/Community-Talk-Staind...
Dec 20 12:47:17 PM  ==> Checking out commit 213170cebdfe26b2f7e8043fe42eef688480fbf5 in branch main
Dec 20 12:47:30 PM  ==> Downloading cache...
Dec 20 12:47:40 PM  ==> Downloaded 288MB in 4s. Extraction took 5s.
Dec 20 12:47:43 PM  ==> Running build command 'bundle install'...
Dec 20 12:47:45 PM  Using rake 13.0.6
Dec 20 12:47:45 PM  Using concurrent-ruby 1.1.9
Dec 20 12:47:45 PM  Using i18n 1.8.11
Dec 20 12:47:45 PM  Using minitest 5.15.0
Dec 20 12:47:45 PM  Using tzinfo 2.0.4
Dec 20 12:47:45 PM  Using zeitwerk 2.5.1
Dec 20 12:47:45 PM  Using activesupport 6.1.4.1
Dec 20 12:47:45 PM  Using builder 3.2.4
Dec 20 12:47:45 PM  Using erubi 1.10.0
Dec 20 12:47:45 PM  Using racc 1.6.0
Dec 20 12:47:45 PM  Using nokogiri 1.12.5 (x86_64-linux)
Dec 20 12:47:45 PM  Using rails-dom-testing 2.0.3
Dec 20 12:47:45 PM  Using crass 1.0.6
Dec 20 12:47:45 PM  Using loofah 2.13.0
Dec 20 12:47:45 PM  Using rails-html-sanitizer 1.4.2
Dec 20 12:47:45 PM  Using actionview 6.1.4.1
Dec 20 12:47:45 PM  Using rack 2.2.3
Dec 20 12:47:45 PM  Using rack-test 1.1.0
Dec 20 12:47:45 PM  Using actionpack 6.1.4.1
Dec 20 12:47:45 PM  Using globalid 1.0.0
Dec 20 12:47:45 PM  Using activejob 6.1.4.1
Dec 20 12:47:45 PM  Using mini_mime 1.1.2
Dec 20 12:47:45 PM  Using mail 2.8.0.edge from https://github.com/discourse/mail.git
Dec 20 12:47:45 PM  Using actionmailer 6.1.4.1
Dec 20 12:47:45 PM  Using actionview_precompiler 0.2.3
Dec 20 12:47:45 PM  Using activemodel 6.1.4.1
Dec 20 12:47:45 PM  Using active_model_serializers 0.8.4
Dec 20 12:47:45 PM  Using activerecord 6.1.4.1
Dec 20 12:47:45 PM  Using public_suffix 4.0.6
Dec 20 12:47:45 PM  Using addressable 2.8.0
Dec 20 12:47:45 PM  Using aws-eventstream 1.2.0
Dec 20 12:47:45 PM  Using aws-partitions 1.516.0
Dec 20 12:47:45 PM  Using aws-sigv4 1.4.0
Dec 20 12:47:45 PM  Using jmespath 1.4.0
Dec 20 12:47:45 PM  Using aws-sdk-core 3.121.2
Dec 20 12:47:45 PM  Using aws-sdk-kms 1.44.0
Dec 20 12:47:45 PM  Using aws-sdk-s3 1.96.1
Dec 20 12:47:45 PM  Using aws-sdk-sns 1.46.0
Dec 20 12:47:45 PM  Using ember-source 2.18.2
Dec 20 12:47:45 PM  Using execjs 2.8.1
Dec 20 12:47:45 PM  Using barber 0.12.2
Dec 20 12:47:45 PM  Using msgpack 1.4.2
Dec 20 12:47:45 PM  Using bootsnap 1.9.3
Dec 20 12:47:45 PM  Using bundler 2.2.26
Dec 20 12:47:45 PM  Using byebug 11.1.3
Dec 20 12:47:45 PM  Using cbor 0.5.9.6
Dec 20 12:47:45 PM  Using chunky_png 1.4.0
Dec 20 12:47:45 PM  Using coderay 1.1.3
Dec 20 12:47:45 PM  Using colored2 3.1.2
Dec 20 12:47:45 PM  Using connection_pool 2.2.5
Dec 20 12:47:45 PM  Using ipaddr 1.2.3
Dec 20 12:47:45 PM  Using openssl 2.2.1
Dec 20 12:47:45 PM  Using openssl-signature_algorithm 1.1.1
Dec 20 12:47:45 PM  Using cose 1.2.0
Dec 20 12:47:45 PM  Using cppjieba_rb 0.3.3
Dec 20 12:47:45 PM  Using css_parser 1.11.0
Dec 20 12:47:45 PM  Using diffy 3.4.0
Dec 20 12:47:45 PM  Using ember-data-source 3.0.2
Dec 20 12:47:45 PM  Using sprockets 3.7.2
Dec 20 12:47:45 PM  Using ember-handlebars-template 0.8.0
Dec 20 12:47:45 PM  Using method_source 1.0.0
Dec 20 12:47:45 PM  Using thor 1.1.0
Dec 20 12:47:45 PM  Using railties 6.1.4.1
Dec 20 12:47:45 PM  Using jquery-rails 4.4.0
Dec 20 12:47:45 PM  Using discourse-ember-rails 0.18.6
Dec 20 12:47:45 PM  Using discourse-ember-source 3.12.2.3
Dec 20 12:47:45 PM  Using discourse-fonts 0.0.9
Dec 20 12:47:45 PM  Using regexp_parser 2.2.0
Dec 20 12:47:45 PM  Using ecma-re-validator 0.3.0
Dec 20 12:47:45 PM  Using email_reply_trimmer 0.1.13
Dec 20 12:47:45 PM  Using excon 0.89.0
Dec 20 12:47:45 PM  Using exifr 1.3.9
Dec 20 12:47:45 PM  Using faraday-em_http 1.0.0
Dec 20 12:47:45 PM  Using faraday-em_synchrony 1.0.0
Dec 20 12:47:45 PM  Using faraday-excon 1.1.0
Dec 20 12:47:45 PM  Using faraday-httpclient 1.0.1
Dec 20 12:47:45 PM  Using faraday-net_http 1.0.1
Dec 20 12:47:45 PM  Using faraday-net_http_persistent 1.2.0
Dec 20 12:47:45 PM  Using faraday-patron 1.0.0
Dec 20 12:47:45 PM  Using faraday-rack 1.0.0
Dec 20 12:47:45 PM  Using multipart-post 2.1.1
Dec 20 12:47:45 PM  Using ruby2_keywords 0.0.5
Dec 20 12:47:45 PM  Using faraday 1.8.0
Dec 20 12:47:45 PM  Using fast_blank 1.0.1
Dec 20 12:47:45 PM  Using fast_xs 0.8.0
Dec 20 12:47:45 PM  Using fastimage 2.2.6
Dec 20 12:47:45 PM  Using ffi 1.15.4
Dec 20 12:47:45 PM  Using fspath 3.1.2
Dec 20 12:47:45 PM  Using gc_tracer 1.5.1
Dec 20 12:47:45 PM  Using guess_html_encoding 0.0.11
Dec 20 12:47:45 PM  Using hana 1.3.7
Dec 20 12:47:45 PM  Using hashie 4.1.0
Dec 20 12:47:45 PM  Using highline 2.0.3
Dec 20 12:47:45 PM  Using hkdf 0.3.0
Dec 20 12:47:45 PM  Using htmlentities 4.3.4
Dec 20 12:47:45 PM  Using http_accept_language 2.1.1
Dec 20 12:47:45 PM  Using image_size 3.0.1
Dec 20 12:47:45 PM  Using in_threads 1.5.4
Dec 20 12:47:45 PM  Using progress 3.6.0
Dec 20 12:47:45 PM  Using image_optim 0.31.1
Dec 20 12:47:45 PM  Using json 2.6.1
Dec 20 12:47:45 PM  Using uri_template 0.7.0
Dec 20 12:47:45 PM  Using json_schemer 0.2.18
Dec 20 12:47:45 PM  Using jwt 2.3.0
Dec 20 12:47:45 PM  Using kgio 2.11.4
Dec 20 12:47:45 PM  Using libv8-node 16.10.0.0 (x86_64-linux)
Dec 20 12:47:45 PM  Using request_store 1.5.0
Dec 20 12:47:45 PM  Using lograge 0.11.2
Dec 20 12:47:45 PM  Using logstash-event 1.2.02
Dec 20 12:47:45 PM  Using logstash-logger 0.26.1
Dec 20 12:47:45 PM  Using logster 2.10.1
Dec 20 12:47:45 PM  Using lru_redux 1.1.0
Dec 20 12:47:45 PM  Using lz4-ruby 0.3.3
Dec 20 12:47:45 PM  Using maxminddb 0.1.22
Dec 20 12:47:45 PM  Using memory_profiler 1.0.0
Dec 20 12:47:45 PM  Using message_bus 3.3.6
Dec 20 12:47:45 PM  Using mini_racer 0.5.0
Dec 20 12:47:45 PM  Using redis 4.5.1
Dec 20 12:47:45 PM  Using sidekiq 6.3.1
Dec 20 12:47:45 PM  Using mini_scheduler 0.13.0
Dec 20 12:47:45 PM  Using mini_sql 1.1.3
Dec 20 12:47:45 PM  Using mini_suffix 0.3.3
Dec 20 12:47:45 PM  Using multi_json 1.15.0
Dec 20 12:47:45 PM  Using multi_xml 0.6.0
Dec 20 12:47:45 PM  Using mustache 1.1.1
Dec 20 12:47:45 PM  Using nio4r 2.5.8
Dec 20 12:47:45 PM  Using oauth 0.5.8
Dec 20 12:47:45 PM  Using oauth2 1.4.7
Dec 20 12:47:45 PM  Using oj 3.13.2
Dec 20 12:47:45 PM  Using omniauth 1.9.1
Dec 20 12:47:45 PM  Using omniauth-oauth2 1.7.2
Dec 20 12:47:45 PM  Using omniauth-facebook 9.0.0
Dec 20 12:47:45 PM  Using omniauth-github 1.4.0
Dec 20 12:47:45 PM  Using omniauth-google-oauth2 0.8.2
Dec 20 12:47:45 PM  Using omniauth-oauth 1.2.0
Dec 20 12:47:45 PM  Using omniauth-twitter 1.4.0
Dec 20 12:47:45 PM  Using optimist 3.0.1
Dec 20 12:47:45 PM  Using pg 1.2.3
Dec 20 12:47:45 PM  Using pry 0.13.1
Dec 20 12:47:45 PM  Using pry-byebug 3.9.0
Dec 20 12:47:45 PM  Using pry-rails 0.3.9
Dec 20 12:47:45 PM  Using puma 5.5.2
Dec 20 12:47:45 PM  Using r2 0.2.7
Dec 20 12:47:45 PM  Using rack-mini-profiler 2.3.3
Dec 20 12:47:45 PM  Using rack-protection 2.1.0
Dec 20 12:47:45 PM  Using rails_failover 0.7.3
Dec 20 12:47:45 PM  Using rails_multisite 4.0.0
Dec 20 12:47:45 PM  Using raindrops 0.20.0
Dec 20 12:47:45 PM  Using rbtrace 0.4.14
Dec 20 12:47:45 PM  Using rchardet 1.8.0
Dec 20 12:47:45 PM  Using redis-namespace 1.8.1
Dec 20 12:47:45 PM  Using rexml 3.2.5
Dec 20 12:47:45 PM  Using rinku 2.0.6
Dec 20 12:47:45 PM  Using rotp 6.2.0
Dec 20 12:47:45 PM  Using rqrcode_core 1.2.0
Dec 20 12:47:45 PM  Using rqrcode 2.1.0
Dec 20 12:47:45 PM  Using rss 0.2.9
Dec 20 12:47:45 PM  Using rtlit 0.0.5
Dec 20 12:47:45 PM  Using ruby-readability 0.7.0
Dec 20 12:47:45 PM  Using rubyzip 2.3.2
Dec 20 12:47:45 PM  Using sanitize 6.0.0
Dec 20 12:47:45 PM  Using sassc 2.0.1
Dec 20 12:47:45 PM  Using sprockets-rails 3.4.2
Dec 20 12:47:45 PM  Using tilt 2.0.10
Dec 20 12:47:45 PM  Using sassc-rails 2.1.2
Dec 20 12:47:45 PM  Using seed-fu 2.3.9
Dec 20 12:47:45 PM  Using sshkey 2.0.0
Dec 20 12:47:45 PM  Using stackprof 0.2.17
Dec 20 12:47:45 PM  Using uglifier 4.2.0
Dec 20 12:47:45 PM  Using unf_ext 0.0.8
Dec 20 12:47:45 PM  Using unf 0.1.4
Dec 20 12:47:45 PM  Using unicorn 6.0.0
Dec 20 12:47:45 PM  Using webpush 1.1.0
Dec 20 12:47:45 PM  Using xorcist 1.1.2
Dec 20 12:47:45 PM  Bundle complete! 127 Gemfile dependencies, 174 gems now installed.
Dec 20 12:47:45 PM  Gems in the groups 'development' and 'test' were not installed.
Dec 20 12:47:45 PM  Bundled gems are installed into `/opt/render/project/.gems`
Dec 20 12:47:45 PM  ==> Generating container image from build...
Dec 20 12:49:52 PM  ==> Uploading build...
Dec 20 12:50:17 PM  ==> Build successful 🎉
Dec 20 12:50:17 PM  ==> Deploying...

And it’s still failing with the same error code

Can someone tell me what the 127 code means and how I can fix it?

It’s not so much the size of the forum, it’s the language/framework the product was written in.

Have you got it up and running locally? That would likely greatly help you when it comes to deploying it us/any other service.

Error code 127 is a bash exit code for command not found.

John B