Certificate error with my custom domain for a few days now


I have the website substital.com on render.

A few days ago I realized we have a ERR_SSL_VERSION_OR_CIPHER_MISMATCH error on the website when coming from the custom domain. I checked similar topic and it seemed to get resolved after some time for some people for that’s not the case for me.

Is there something wrong with my DNS configuration? I went back to the docs and read about CAA records, I added them for my DNS thinking this is what was missing. It’s been 2 days now and still no luck.

https://substital.onrender.com/ is working perfectly. The issue is only with the custom domain.

Could someone help? Let me know if you need more information. Thanks!

Hey Gaetan,

Thanks for getting in touch.

Apologies for this - I’ve checked the domain and it was all configured correctly, we had issued the www certificate but not the apex domain due to a time out at the certificate provider - which we do normally retry. I’ve just pushed through a refresh and can see the certificate has been issued and the site is now accessible, please confirm?


John B

It works now! :slight_smile: Thank you so much for the super quick answer.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.