Build Failed After trying to download pyarrow

I was able to get the app to run when I used the steamlit run command prompt, however, now it is failing using render. I keep getting the same message about the pip. After trying to upgrade, command prompt said that there is no need to upgrade and I am using the correct pip version (which is 22.3.1) …I also wasn’t sure if I was supposed to list the complete pip freeze list in my github repository, after editing and just having the minimum requirements (streamlit, pandas, and plotly-express) listed in the .txt, it does the same thing.
*Uploaded screenshot for reference
**FYI, I am still pretty new at using render and coding altogether. Please do you best to explain in lamen terms lol

Not sure if this matters, but this is the current pip freeze list on my venv:
altair==4.2.0
attrs==22.2.0
blinker==1.5
cachetools==5.2.1
certifi==2022.12.7
charset-normalizer==2.1.1
click==8.1.3
colorama==0.4.6
commonmark==0.9.1
decorator==5.1.1
entrypoints==0.4
gitdb==4.0.10
GitPython==3.1.30
idna==3.4
importlib-metadata==6.0.0
Jinja2==3.1.2
jsonschema==4.17.3
MarkupSafe==2.1.1
numpy==1.24.1
packaging==23.0
pandas==1.5.2
patsy==0.5.3
Pillow==9.4.0
plotly==5.11.0
plotly-express==0.4.1
protobuf==3.20.3
pyarrow==10.0.1
pydeck==0.8.0
Pygments==2.14.0
Pympler==1.0.1
pyrsistent==0.19.3
python-dateutil==2.8.2
pytz==2022.7
pytz-deprecation-shim==0.1.0.post0
requests==2.28.1
rich==13.0.1
scipy==1.10.0
semver==2.13.0
six==1.16.0
smmap==5.0.0
statsmodels==0.13.5
streamlit==1.16.0
tenacity==8.1.0
toml==0.10.2
toolz==0.12.0
tornado==6.2
typing_extensions==4.4.0
tzdata==2022.7
tzlocal==4.2
urllib3==1.26.13
validators==0.20.0
watchdog==2.2.1
zipp==3.11.0

Hi Michelle

The pip version warning is fine, pip downloads your packages and is generally stable from version to version and that is not what is breaking.

From your screenshot, I think I see you are using the Render default Python version of 3.7. I’d recommend using Python 3.9 (a more recent and more supported Python version). You can change this with a Render environment variable on your project settings:

In more detail, many of these Python packages you are using have compiled parts which are more likely to cause problems and fail to install. Using a higher Python version will have more compatabibility with pre-built Python packages, especially since you are using the latest version of many packages. For example, the latest version of numpy (1.24.1) that you are using doesn’t seem to be offering pre-built packages for Python 3.7: numpy · PyPI

Goodluck!

1 Like

Thanks! I will try that

1 Like