/bin/sh: 1: nest: not found

I’m trying to deploy a NestJS project. While the build command works locally, when I try to do the same through Render, I get the following error:

Nov 20 01:34:04 PM  ==> Cloning from https://github.com/3mint/3mint-api...
Nov 20 01:34:04 PM  ==> Checking out commit 9b7f72973fe76dea71a292d09d356bd1e9cbaf3a in branch master
Nov 20 01:34:07 PM  ==> Downloading cache...
Nov 20 01:34:27 PM  ==> Transferred 238MB in 10s. Extraction took 8s.
Nov 20 01:34:30 PM  ==> Detected Node version 16.14.0
Nov 20 01:34:30 PM  ==> Running build command 'yarn; yarn build'...
Nov 20 01:34:30 PM  yarn install v1.22.5
Nov 20 01:34:30 PM  [1/4] Resolving packages...
Nov 20 01:34:31 PM  [2/4] Fetching packages...
Nov 20 01:35:07 PM  [3/4] Linking dependencies...
Nov 20 01:35:07 PM  warning Workspaces can only be enabled in private projects.
Nov 20 01:35:19 PM  [4/4] Building fresh packages...
Nov 20 01:35:25 PM  Done in 54.43s.
Nov 20 01:35:25 PM  yarn run v1.22.5
Nov 20 01:35:25 PM  $ rimraf dist
Nov 20 01:35:25 PM  $ nest build
Nov 20 01:35:25 PM  /bin/sh: 1: nest: not found
Nov 20 01:35:25 PM  error Command failed with exit code 127.
Nov 20 01:35:25 PM  info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
Nov 20 01:35:25 PM  ==> Build failed 😞

Does anyone know why this may be caused?

Hi Dimitri,

How are you installing the nest library? You may need to ensure it’s available on your PATH. For example, you might need to have a build script that runs your npm install or similar, then add nest to your PATH with something like export PATH="$PATH:/opt/render/project/src/node_modules/nest/bin".

You’d want to confirm this is where nest was installed. And you may need to do the same as a part of your Start Command.

Let me know if that helps you make progress, or if you have any questions.

Regards,

Matt