Yt-dlp file is not running on my web service

I was developing my app on my local windows 10 system and it works fine, but when i uploaded the app on render it started showing this Error:

its a nodejs app , thanks :wave:

on the npm package page the second line says:
YT-dlp itself will not be automatically downloaded
you can install yt-dlp in your deploy step using
pip install yt-dlp
you will have to modify your javascript to use the python version instead of the win32 version
read this entire page: yt-dlp-wrap - npm

I have replaced the win_32 version with the linux version and got the same error, I think its a permission issue because the linux version should work properly, do u have any ideas on changing folder’s permissions on render?

by the way this is the linux version i used:

[SOLVED]: It’s a permissions issue as the web service is running on linux, i tried to change the file permissions via shell but it’s paid and can’t be accessible by free instances so I used the command along with the build command so that it changes yt-dlp file permissions on each deploy.

Go to your Dashboard :point_right: Build & Deploy :point_right: Build Command and set it to:

npm install; chmod -R 777 ./yt-dlp

Note: This method is for free instances (paid instances can do it through the shell).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.