Uvicorn service starts but site isnt deployed

Apr 11 08:52:20 PM ==> Starting service with ‘uvicorn app:cfd’
Apr 11 08:52:25 PM INFO: Started server process [36]
Apr 11 08:52:25 PM INFO: Waiting for application startup.
Apr 11 08:52:25 PM INFO: Application startup complete.
Apr 11 08:52:25 PM INFO: Uvicorn running on http://127.0.0.1:8000 (Press CTRL+C to quit)

Logs shows build successful and service starts but main site shows nothing
I am using port 8000 and build command uvicorn app:cfd
It works on Localhost but not when I deploy

Hi @Mitesh_Metha ,

Looking at your logs, I see this:

Apr 11 08:33:43 AM  INFO:     Uvicorn running on http://127.0.0.1:8000 (Press CTRL+C to quit)
Apr 11 08:37:07 AM  INFO:     Shutting down

where your server shuts down after 4 seconds. I recommend adding additional logging, or increasing log verbosity, to understand why your server is shutting down. From your logs, it looks like it might also only be listening on IP address 127.0.0.1, but Render requires that you are listening on address 0.0.0.0.

Awesome Team man !!! This Helped I just edited build command to uvicorn app:cfd --host 0.0.0.0 --port 80 and It worked.

Render is Love :star_struck: :slight_smile:

Awesome! Glad it helped! :heart:

Here a short comparsion why Render is Awesome !

Heroku : Tried same app on heroku it isnt deployed as faced error over buildpack as I needed dlib and heroku didnt even start the service and also a point to note lib.so took over 300MB so Heroku kept crashing

Render : Tried similar thing service started just i wasnt able to see output started a topic and just upadting build command and everything is running render took care of all dependencies

Hetzner Cloud : A lot of installation to be done right from Cmake, Dlib consuming a lot of time

Render wins everywhere here :heart: Kudos!!!

4 Likes