Using initialDeployHook with Docker

I’m having issues with using the Preview Environment initialDeployHook parameter with a Docker service environment.

My service calls a script that’s within the docker and the Initial Deploy Hook starts, but immediately ends in failure with no error logs in the Render web ui (ex: https://dashboard.render.com/web/.../deploys/...?initialDeployHookLogs=true).

The service looks something like this:

  - type: web
    env: docker
    ....
    dockerfilePath: ./Dockerfile
    dockerCommand: /app/scripts/start-web.sh
    initialDeployHook: /app/scripts/seed-database.sh
    ....

Notably, the script does run to completion if I open a shell connection to the service and run the same line (/app/scripts/seed-database.sh). Using a relative path (ex initialDeployHook: ./scripts/seed-database.sh) has the same result.

Any ideas why it’s failing and why I can’t get any error logs for it?

Matthew,
We’ve recently been fighting some logging daemons and especially for the initialdeployHook - do you have an preview environment up at the moment that we can take a look at what’s going on?

John B

I’ve PM’d you a link an environment I just spawned. Hope this helps!

It would appear that something changed on Render’s end between my deploys last week and this week and the Deploy Hook script worked this time. I’ll close this for now.