Stuck at Postgres database error + error in sync?

I am trying to deploy a one page Rails site on the free services, and I am stumbling into a lot of trouble, but I’m getting through, one step at a time. I’m trying to follow this guide here:

I keep getting an error:

Nov 26 11:21:22 PM rails aborted!
Nov 26 11:21:22 PM PG::ConnectionBad: connection to server on socket "*/var/run/postgresql/*.s.PGSQL.5432" failed: No such file or directory
Nov 26 11:21:22 PM Is the server running locally and accepting connections on that socket?

I am trying to cover all possibilities, but something is surely missing, because the site runs locally.

Also, when I go to the Blueprint Syncs, and try to do a Manual Sync, I get this error:

We weren’t able to fully sync these resources. Try again?

I’ve tried it several times, and I can’t also see the details on the errors.

Can you please help me with this? Thanks in advance.

Best regards,

Hi John,

Thanks for reaching out.

I see you’ve also opened a ticket, so we’ll keep our conversation there for now. Maybe you can share the solution with the community once we get to the bottom of your issue.

Kind regards


Thanks for your help, Al. Apparently I was confused about something with the services and the blueprints, did it from scratch and it worked as expected.

Appreciate your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.