Static site deploy failed due to rubygems-update failures

My static site deploy failed strange message:

Updating rubygems-update
    undefined method `version' for nil:NilClass
 PMERROR: While executing gem ... (NoMethodError)
	rubygems-update requires Ruby version >= 3.0.0. The current ruby version is
	There are no versions of rubygems-update (= 3.5.0) compatible with your Ruby & RubyGems
 PMERROR: Error installing rubygems-update:

I’m not using ruby but node + vitejs and simple npm run build build command

I’ve tried again with same result.

Is it possible to disable rubygems-update installation?

Just a small detail: I’m not deploying to production on Friday evening.
It’s about a Pull request preview

We just started seeing this as well in our staging environment. I’m also confused why both Ruby and Python are being installed for a Node app.

I can’t speak to why Ruby is being installed for a Node app, but I was able to fix this by adding .ruby-version to the root of my project with the value “3.2.2”.

Render has updated their default Ruby version and I suspect whatever is making rubygems-update happen is not accounting for the fact that projects may still be on ruby 2.x if they were created before November 01, 2023.

Hi there,

Evan is pretty much correct here. We’ve rolled out a fix that should clear up the problem. Try redeploying now.


Render Support Engineer, MT (UTC-7)

Deploys are working fine now.

However the deploy log now contains hundreds of lines of RubyGems changelog which is very noisy.

I am experiencing the same problem when I want to deploy to any project I have added.

Hi Syngeos Developer,

Do you mind sharing the service id so we can go in and take a look at those logs? If not, you can reach out to us privately via the Help link in the Render Dashboard.


Just to confirm, you are experiencing the same issue as Syngeos Developer regarding noisy Ruby changelogs?


Render Support Engineer, MT (UTC-7)

Noisy logs were present on 2023-12-17 (I can still access that logs in the dashboard)
Next day when I pushed new commit that triggered auto-deploy, logs were back to normal so I guess the issue is fixed now.

If are still interested in details, I can create new ticket via dashboard but I’d say the issue is solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.