Set your homepage to the render homepage url for your front-end app

Hi, new student here. I was trying to deploy the front-end part of my create-react-app with Render. I followed the guidlines and ran the deploy, but I was just getting a blank page and an error code saying:

Failed to load resource: the server responded with a status of 404 ()

Refused to execute script from ‘https://facial-recognition-app-90kw.onrender.com/Facial-Recognition-APP/static/js/main.e5ec5c3a.js’ because its MIME type (‘text/plain’) is not executable, and strict MIME type checking is enabled.

Manifest: Line: 1, column: 1, Syntax error.

It turned out that all it was was my package.json “homepage” value wasn’t set to the url given to me by Render once I had it built. Maybe this is just my noob mistake, but I couldn’t find anything online that helped me out, and I would think it would be a common issue.

Is there somewhere on the Render website where this issue is addressed?

Hi Chris,

Thanks for sharing information that helped your application!

Regards,
Mike


Render Support Engineer, MT (UTC-6, UTC-7 in Winter)