Plolty Dash App not Deploying anymore

I’ve been using Render for some time to deploy some python code as a web app using Dash package (it should create a Flask app as far as I understand).
The problem is that Render is not working anymore when i try to deploy this type of app.
I had 3 working apps (the last deployed 3 months ago) and i tried deploying another one today. After reading build successful in the logs i tried opening the app but i found an error 502 on the website. On my Render dashboard it looks like the deploy is stuck at ‘deploying’ status even though in the logs i can see ‘deployed successfully’.
At first i thought it was a bug in my new code, but then i tried redeploying a working web app that has not been modified in the last 3 months and now it cannot be deployed anymore either.
The deploying status goes on and on and eventually it times out. I checked and the other 2 web apps deployed months ago still works (but i haven’t tried deploying them again).
Something happened to Render workflow that makes it impossible to deploy Dash app now.
Can you please help me in any way to find a solution?

Hi there,

We did introduce a recent change to our Free-tier infrastructure that requires your application to bind to, and not or localhost.

Could you ensure all your services are binding to and let me know if that helps.



Yes now it works thank you.
For anyone having this same problem just use
and it should work

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.