Passing ssh key to dockerfile in web service

Hi, I would like to know if it is possible to build and run my own dockerfile when building a web service based on a github repo. I tried using the docker command for the web service but it seems that docker is not installed as it says the command is not found.

i did not realise that it was not possible to change the runtime of the service after creation. i found out it is possible to select docker, so my original question is solved. However, I would like to ask a follow-up question:

How would like mount an ssh key so that the dockerfile can use it? Or is there a setting where I can override the docker build command?

librypto throws an error while trying to read the ssh key file. I am assuming that this is an error in how render allows pasting of file content. It seems the last endline is always deleted, and I am guessing this is causing an error with the key parsing. Is there a solution to work around this?


Troubleshooting SSH failures during Docker deployment can be complex, given that the environment isn’t within our control. I would suggest referring to for guidance. Additionally, ensure that OpenSSH is installed in the image

Render Support, UTC+3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.