One-off job start command path?

I want to create a one-off job calling test.py but I can’t get it to work.
My serviceId and bearer are correct, but the script always exits with status 2.
test.py only contains print(“good”) and I have tried all possible paths between /opt/render/project/src/test.py and test.py.

if i run the startCommande directly from the shell, it works.

any idea ?

i ran the test from Create job

curl --request POST
–url https://api.render.com/v1/services/srv-cm9999999999/jobs
–header ‘accept: application/json’
–header ‘authorization: Bearer rnd_999999999999999’
–header ‘content-type: application/json’
–data ’
{
“startCommand”: “python /opt/render/project/src/test.py”
}

Hi Sebastien,

I’d be curious to know what you see if your run a job with a startCommand  of which python and compare that to what you have in the shell.

It could be helpful to have some specific information about your service. If you could share a service ID, that would be helpful. Feel free to open if you don’t want to share that information in a public forum.

Regards,

Matt

I thought the service ID was the server ID? If not, where can I find the service ID?

It’s what starts with srv-.... It’s in the URL of your API request.

thanks for your time,

Ok, i use the good srv-… because In the logs of the jobs sections on render I can see : “python: can’t open file ‘/opt/render/project/src/test.py’”

But if I run the same command “python /opt/render/project/src/test.py” in the shell section it works

Any idea ?

Hi Sebastien,

Can you tell me the service id so I can take a look at this on my end?

Regards,

Matt