One-click Redash deploy does not work

The one-click deploy for Redash on this page does not seem to work: Deploy Redash | Render · Cloud Hosting for Developers

The deploy is successful, but any attempts to load the Redash web interface results in a 502. From the logs, it seems the workers continually timeout and respawn. However, I can’t find any meaningful logs about what is actually causing the timeouts.

The blueprint uses the latest version of Redash (v10), so I also tried forking the repo and switching the Docker image to v8, but this had the same result.

Someone mentioned that this may be happening because Redash needs 4GB of memory and the standard plan only provides 2. I tried upgrading our deployment to Pro to get 4GB but that also did not seem to work.

I’ve not yet tried to go through the manual steps to deploy Redash, I may try that next. But it would be so awesome if the one-click deploy was working!

Hi @pifantastic,

I’ve just tried testing this as well based on the template defaults. I did run into the same 500 error initially when accessing the redash app. There is an extra step in the guide to create the database. I noticed that the query to the database failed without it because it was missing the expected tables.

Can you let me know if the deploy works after running render-redash create_db from your service’s web shell?

https://render.com/docs/deploy-redash#one-click-deploy

Thanks for taking a look @Jade_Paoletta.

I am fairly certain that I did run the created_db command. I can see the Redash tables in my postgres instance. The service is suspended right now, so I can’t double check.

Is it working okay for you after creating the tables?

@John_B uh…what? :smiley:

It’s a bug we need to fix :slight_smile:

Same. Get 502 bad gateway.
Here are some logs:

redash@srv-c9q6isk6fj38urep0krg-675f699c79-vltgh:/app$ render-redash create_db
[2022-05-06 17:51:01,692][PID:75135][INFO][alembic.runtime.migration] Context impl PostgresqlImpl.
[2022-05-06 17:51:01,693][PID:75135][INFO][alembic.runtime.migration] Will assume transactional DDL.

While this script was running, I didn’t see anything in the DB instance’s logs around creating tables.

Is it fixed?