Not able to locate index.html in rewrite rule


I have spun a static site, built as a React app. It is built as part of a monorepo using NX. I have been able to get the app working just fine, set my publish directory to dist/apps/app-name.

But when i try to setup a rewrite rule from
/* → dist/apps/app-name/index.html
it does not work. I do get a status code 200 on a request to a sub-page like “/events” but the response is empty.

I know i’m just doing something wrong, but if someone can give me a htnt as to what the problem might be, it would be greatly appreaciated.

Thank you.

Best regards,

Hi Marrtin,

Could you try setting it to just /index.html?

Give that a try and let me know how it goes.



This is embarassing :slight_smile: I was 100% sure that i had already tried that when i read your answer, but it worked with your suggestion so I must have not tried it previously.

THanks for the reply!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.