Not able to get vite while deploying

My package.json file in D:\project\fwitter\package.json
{
“name”: “twitwer”,
“version”: “1.0.0”,
“main”: “backend/server.js”,
“scripts”: {
“dev”: “nodemon backend/server.js”,
“start”: “node backend/server.js”,
“build”: “npm install && npm install --prefix frontend && npm run build --prefix frontend”
},
“keywords”: ,
“author”: “”,
“type”: “module”,
“license”: “ISC”,
“description”: “”,
“dependencies”: {
“bcryptjs”: “^2.4.3”,
“cloudinary”: “^2.2.0”,
“cookie-parser”: “^1.4.6”,
“cors”: “^2.8.5”,
“dotenv”: “^16.4.5”,
“express”: “^4.19.2”,
“jsonwebtoken”: “^9.0.2”,
“mongoose”: “^8.4.1”
},
“devDependencies”: {
“cross-env”: “^7.0.3”,
“nodemon”: “^3.1.3”
}
}
And my D:\project\fwitter\frontend\package.json
{
“name”: “frontend”,
“private”: true,
“version”: “0.0.0”,
“type”: “module”,
“scripts”: {
“dev”: “vite”,
“build”: “vite build”,
“lint”: “eslint . --ext js,jsx --report-unused-disable-directives --max-warnings 0”,
“preview”: “vite preview”
},
“dependencies”: {
“@tanstack/react-query”: “^5.45.0”,
“react”: “^18.2.0”,
“react-dom”: “^18.2.0”,
“react-hot-toast”: “^2.4.1”,
“react-icons”: “^5.2.1”,
“react-router-dom”: “^6.23.1”,
“twitwer”: “file:…”
},
“devDependencies”: {
“@types/react”: “^18.2.66”,
“@types/react-dom”: “^18.2.22”,
“@vitejs/plugin-react”: “^4.2.1”,
“autoprefixer”: “^10.4.19”,
“daisyui”: “^4.12.2”,
“eslint”: “^8.57.0”,
“eslint-plugin-react”: “^7.34.1”,
“eslint-plugin-react-hooks”: “^4.6.0”,
“eslint-plugin-react-refresh”: “^0.4.6”,
“postcss”: “^8.4.38”,
“tailwindcss”: “^3.4.4”,
“vite”: “^5.2.0”
}
}
I am using npm run build and then using npm run start in D:\project\fwitter to run the application.

Hi there,

If you are setting NODE_ENV to production it will not install devDependencies.

Regards,

Keith
Render Support, UTC+10 :australia: