NODE_VERSION not working anymore

I did a push to today like normal but when render tried to build it failed because it trued using the latest version of node. I haven’t changed anything but some css files and now render keeps trying to use the latest version and is ignoring the NODE_VERSION environmental variable in render. Any help would be greatly appreciated.

I should mention I’ve gone over the docs and that’s how I was downgrading node previously. It has been working for a month or 2 but all of a sudden it won’t anymore.

Hi Matthew,

I’ve responded to your internal ticket regarding this issue. To summarize:

  • This was related to a bug, which is now being worked on
  • A temporary fix was put in place, so the issue should now be resolved

Regards,
Mike


Render Support Engineer, MT (UTC-6, UTC-7 in Winter)