No rendering of three js component

Hi Guys
glad to be in touch with you , I have recently been developing a website with Three JS , I ran on a local host it worked perfectly then I went to production I ran npm run build then I deployed on [](javascript:void(0):wink: but unfortunately it did not render the page content only HTML content appeared and not formatted even plus no three js website in there What is the issue do you think ? please help me
this is the link to the website showing the problem

please help me resolve this issue
with Kind Regards


There will always be differences between environments: development mode/Local, production mode/Render, etc. These differences need to be considered and configured as required for your own app in each environment.

It’s hard to troubleshoot without any specific details. This doesn’t sound like a Render issue, but we can certainly try and assist you in getting up and running.

When asking for assistance, please elaborate on your issue in as much detail as possible, e.g. specific URLs, any logs/error messages, reproduction steps, screenshots, etc. to show the problem you’re experiencing.

If you don’t want to share these details on the community forum, please feel free to raise a ticket from the “Help” or “Contact Support” links while logged into the Dashboard.


Thank for your response here is the link to my GitHub repository : GitHub - Datascientist88/AIHub as well as the final deployed version is this one : thanks once again for your kind cooperation please help me overcome this strange deployment issue this is the logging during the deployment

with best regards

Your HTML is looking for but that’s not found.

The asset is deployed to

You’ll need to ensure your asset paths are correct.


Thank you so much I did run the production mode npm run build and gone through the deployment process by specifying the dist folder as the path to source of built project but it did not work the same situation persist any clue how to determine the correct asset path I noticed the built folder dist contain only HTML no JavaScript in there

Code debugging is beyond the scope of our support, maybe another community member will be able to help.

But as a starting point, the issue appear to 3d-portfolio being included in the path, which doesn’t seem to be be required. So that would be configuration of your build:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.