MinIO default deployment, calls to port 9000 times out

Hey – first topic and rather desperate since my image uploading service is currently in outage mode and I can’t seem to get a response from the support chat :frowning:

I did the one-click deployment of MinIO (per Deploy MinIO | Render · Cloud Hosting for Developers), and everything is the default settings. I’m having no trouble accessing the dashboard, setting up users, etc.

However, when I try to do any calls to the server, using any of the users I create or the ROOT user I get from the env variables, the request times out and can’t seem to connect to the server. I am making calls to port 9000 – as the console logs say this port is active on my server for the API when it starts up (I have also tried the ENV port, 10000, with the same timeout result)

Simply changing my env variables to the play.minio.io url (and setting up a user there in the same way I am on my application) works 100%, so it does not appear to be a code problem.

Am I missing something here? Is there a setting I need to change from the defaults in order for this to work?

Thanks in advance

Changing the PORT env variable to 9000 does not seem to help either, the result is the same. I’m actually not even sure why the health check is passing when I redeploy after updating that variable, that URL times out as well…

Hey Billy,

I suspect you’re running into what we detail in the Readme for the service https://github.com/render-examples/minio#minio-on-render

The MinIO web console and MinIO API listen on different ports. Because Render only exposes one port publicly for Web Services, you must decide which you want to expose. By default, the console is exposed publicly. Change PORT to 9000 to switch to the API being exposed publicly. You can see (or modify) the console and API port definitions in this repository’s entrypoint.sh file.

Did you fork the example repo here so that you can change the PORT in the render.yaml to 9000so that we connect to the API service as opposed to the webconsole?

Regards,

John B

Thanks. I’ve already pursued another option, but I will give this a try if I need to return to this approach.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.