Limitation on number of apps (web services) on free tier

Thank you for making app deployment so easy with Render. This is a wonderful product.

Two days ago I had deployed a Dash data app to the web, using Render’s free tier. That worked. Then, yesterday, I deployed another web service (new Dash app), using the free tier, but it did not work; it was stuck on “loading…”.

I suspended the first web service I created two days ago, and today the second app works.

Does this mean that one cannot deploy more than one app on render’s free tier?
I couldn’t find any documentation on the matter.

Hey Adam,

We limit the number of free databases you can have active to 1 but not webservices, they are limited by the number of usage hours your account has remaining.

I’m not even sure we have a “Loading…” state, could you try again and if you see this behaviour provide a screenshot perhaps?

John B

1 Like

Thank you for the quick response, @John_B.

I spent over an hour yesterday try to debug my second app to make it work, because I kept seeing this on my screen without it ever rendering anything:

I ended up not changing anything, except for pausing the first app web service. And today the second app suddenly worked, which is why I assumed it had to do with the number of web services used. But I’m glad that’s not the case.

I wonder what was wrong :thinking:

If it happens again with future apps, I’ll add a post to this topic. Thank you for your support.

That’s not a Render output there - that’s coming from your own service. Did the network inspector show anything perhaps?

But you’re most welcome to add here if it comes up again and we can advise,

John B

How do I access the network inspector? Is it when I right click on the mouse and click Inspect?

yes, exactly that - that screenshot looks to me like it’s waiting the response from a javascript async event possibly

John B

Thanks @John_B.
I will do that next time to try to figure out any errors. I believe my experience yesterday had to do with this post, since I also used Ohio.

1 Like

Gotcha, that could be the likely culprit here.

John B

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.