Failed to deploy python quart app

I encountered an error when deploying a Python Quart application. I had successfully deployed it before, but when I attempted to redeploy it, I encountered an error. To troubleshoot, I created a simple Python Quart app that just returns ‘hello world,’ but I still encountered the same error, I can’t install the latest Python Quart because of the default python version which is 3.7, provided by render.

  1. Requirement.txt:


  1. Start command:

hypercorn -b app:app

  1. Source code:
from quart import Quart

app = Quart(__name__)

async def hello_world():
    return 'Hello, World!'
  1. Error message

Hi there,

You can specify a higher version of Python via an environment variable:

That may solve the problem, but if it doesn’t let us know and we will be happy to take another look.


Render Support Engineer, MT (UTC-6)

Thanks. The problem is now solved.

Hi there,

Glad you got things resolved! Do you mind sharing what worked?


Render Support Engineer, MT (UTC-7)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.