Disable Autocomplete in Rails Console

The autocomplete in the rails console messes with the functionality and history of the console. I have been able to temporarily disable autocomplete in the rails console inside of the shell each time with touch ~/.irbrc && echo "IRB.conf[:USE_AUTOCOMPLETE] = false" >> ~/.irbrc. Is there an easier way to accomplish this in the shell?

There are a few workarounds you can make to address this.

Just a few options

  1. Start the console with (optionally wrapping this up in a little shell script to avoid repeating yourself)

    rails console – --noautocomplete

  2. Keeping with the approach you outlined, you could add the following to your start command/start script

    touch ~/.irbrc && echo “IRB.conf[:USE_AUTOCOMPLETE] = false” >> ~/.irbrc

  3. Lastly, sshing into your machine instead of using the web shell could make for a better experience.

It also looks like this is a common complaint, and there are a few changes in the works to address this

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.