Deploying a django application

i have been tryin to deploy a djano application for sometime now but it keeps failing i get the following erros:
ERROR: No matching distribution found for Django==4.1.2 (from -r requirements.txt (line 6))
Dec 24 10:49:57 PM WARNING: You are using pip version 20.1.1; however, version 22.3.1 is available.
Dec 24 10:49:57 PM You should consider upgrading via the ‘/opt/render/project/src/.venv/bin/python -m pip install --upgrade pip’ command.
Dec 24 10:49:57 PM ==> Build failed :disappointed:
Dec 24 10:49:57 PM ==> Generating container image from build. This may take a few minutes…

Hi there,

The error in the logs you shared is:

ERROR: No matching distribution found for Django==4.1.2

Django 4.1.2 requires Python >=3.8.

I expect further up in those logs you would see:

Using Python version: 3.7.10

Which is the default version on a Render Native Environment.

Specify your Python Version to match the one you use to develop locally.


thank you it worked , it recognises the python version however it now says
ModuleNotFoundError: No module named ‘app’
not sure why

from Dashbord Select the web_service your deploying

go to settings.
in the Start Command: gunicorn <ur_django_app>.wsgi

just replace the <ur_django _app> with your app without the square brackets

thank you it worked however im now struggling with dns settings im getting this error

Secure Connection Failed

An error occurred during a connection to Cannot communicate securely with peer: no common encryption algorithm(s).


The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

and in my settings it says certificate error

I’m not seeing an SSL error on that domain, but I am seeing a 400 error which comes from your code. As the error message shows, it’s related to the Django ALLOWED_HOSTS configuration.

Invalid HTTP_HOST header: ''. You may need to add '' to ALLOWED_HOSTS.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.