Deploy Error with Next.JS and Styled-Components


I am getting this error when trying to deploy my static website:

I have even tried to deploy the same commit that worked some weeks ago, but i get the same error.

These are my dependencies:
“dependencies”: {
“@types/node”: “20.2.5”,
“@types/react”: “18.2.8”,
“@types/react-dom”: “18.2.4”,
“autoprefixer”: “10.4.14”,
“next”: “13.4.4”,
“phosphor-react”: “^1.4.1”,
“postcss”: “8.4.24”,
“react”: “18.2.0”,
“react-dom”: “18.2.0”,
“react-is”: “^18.2.0”,
“react-modal”: “^3.16.1”,
“react-responsive”: “^9.0.2”,
“styled-components”: “^6.0.0-rc.1”,
“tailwindcss”: “3.3.2”,
“typescript”: “5.1.3”,
“wow.js”: “^1.2.2”
“devDependencies”: {
“@types/react”: “18.2.0”,
“@types/react-dom”: “18.2.0”,
“@types/react-modal”: “^3.16.0”,
“@types/styled-components”: “^5.1.26”

What could be going on?


I found that the same problem happened in Vercel, so this is not a related problem.

I had to downgrade @types/react from 18.2 to 18.0.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.